aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT2000/176.gcc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'External/SPEC/CINT2000/176.gcc/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT2000/176.gcc/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/External/SPEC/CINT2000/176.gcc/CMakeLists.txt b/External/SPEC/CINT2000/176.gcc/CMakeLists.txt
index d1a85a0a..99683bf0 100644
--- a/External/SPEC/CINT2000/176.gcc/CMakeLists.txt
+++ b/External/SPEC/CINT2000/176.gcc/CMakeLists.txt
@@ -10,13 +10,11 @@ list(APPEND CFLAGS -std=gnu89)
list(APPEND CPPFLAGS -D__DATE__="XXX" -D__TIME__="XXX")
macro(test_input run_type ifile sfile)
- llvm_test_run(RUN_TYPE ${run_type}
- ${BENCHMARK_DIR}/data/${run_type}/input/${ifile}
- -o ${CMAKE_CURRENT_BINARY_DIR}/${sfile}
+ llvm_test_run(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ data/${run_type}/input/${ifile} -o ${sfile}
)
- llvm_test_verify(RUN_TYPE ${run_type} ${FPCMP}
- ${BENCHMARK_DIR}/data/${run_type}/output/${sfile}
- ${CMAKE_CURRENT_BINARY_DIR}/${sfile}
+ llvm_test_verify(RUN_TYPE ${run_type} WORKDIR ${CMAKE_CURRENT_BINARY_DIR}
+ ${FPCMP} data/${run_type}/output/${sfile} ${sfile}
)
endmacro()
@@ -28,4 +26,5 @@ test_input(ref scilab.i scilab.s)
test_input(train cp-decl.i cp-decl.s)
test_input(test cccp.i cccp.s)
-llvm_test_executable(${PROG} ${Source})
+llvm_test_executable(176.gcc ${Source})
+llvm_test_data_spec_default(176.gcc)