aboutsummaryrefslogtreecommitdiff
path: root/MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
committerMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
commit81930acd88c60992449cd29417fa29ef6ca480a5 (patch)
tree538eca0d0a20bca95dcbd9298c007b4145914463 /MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt
parenta1fbbc9edcfb0988e0e25171f6bc5bd67f43430c (diff)
cmake: Explicitely specify benchmark data
Explicitely declare what files are used as inputs for the benchmarks. This changes the benchmarks to: - Symlink (or copy) the related input files next to the binary into the build folder. - Set the working directory of the benchmark to be the folder of the executable. - Having the data next to the binary also reduces the amount of absolute paths in the test files. - Contains some smaller cleanups for SPEC95/2000/2006 files while adapting to the new data copying style. With this change in place you do not need the test-suite source repository anymore to run the benchmarks. This is an important step towards having a test-suite that can be cross-compiled on a host, then copied onto a device and ran there without having a shared filesystem like NFS setup. Differential Revision: https://reviews.llvm.org/D50209 git-svn-id: https://llvm.org/svn/llvm-project/test-suite/trunk@340582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt')
-rw-r--r--MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt b/MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt
index 7bb6a84f..d1f2e3b1 100644
--- a/MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt
+++ b/MultiSource/Benchmarks/MallocBench/p2c/CMakeLists.txt
@@ -1,3 +1,4 @@
list(APPEND CPPFLAGS -DNOMEMOPT)
-set(RUN_OPTIONS -v < ${CMAKE_CURRENT_SOURCE_DIR}/INPUT/mf.p)
+set(RUN_OPTIONS -v < INPUT/mf.p)
llvm_multisource(p2c)
+llvm_test_data(p2c INPUT/mf.p)