aboutsummaryrefslogtreecommitdiff
path: root/MultiSource/Applications/kimwitu++/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
committerMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
commit81930acd88c60992449cd29417fa29ef6ca480a5 (patch)
tree538eca0d0a20bca95dcbd9298c007b4145914463 /MultiSource/Applications/kimwitu++/CMakeLists.txt
parenta1fbbc9edcfb0988e0e25171f6bc5bd67f43430c (diff)
cmake: Explicitely specify benchmark data
Explicitely declare what files are used as inputs for the benchmarks. This changes the benchmarks to: - Symlink (or copy) the related input files next to the binary into the build folder. - Set the working directory of the benchmark to be the folder of the executable. - Having the data next to the binary also reduces the amount of absolute paths in the test files. - Contains some smaller cleanups for SPEC95/2000/2006 files while adapting to the new data copying style. With this change in place you do not need the test-suite source repository anymore to run the benchmarks. This is an important step towards having a test-suite that can be cross-compiled on a host, then copied onto a device and ran there without having a shared filesystem like NFS setup. Differential Revision: https://reviews.llvm.org/D50209 git-svn-id: https://llvm.org/svn/llvm-project/test-suite/trunk@340582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'MultiSource/Applications/kimwitu++/CMakeLists.txt')
-rw-r--r--MultiSource/Applications/kimwitu++/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/MultiSource/Applications/kimwitu++/CMakeLists.txt b/MultiSource/Applications/kimwitu++/CMakeLists.txt
index a0f771aa..04c95c7f 100644
--- a/MultiSource/Applications/kimwitu++/CMakeLists.txt
+++ b/MultiSource/Applications/kimwitu++/CMakeLists.txt
@@ -1,6 +1,6 @@
list(APPEND CPPFLAGS -I${CMAKE_CURRENT_SOURCE_DIR} -DYYDEBUG=1)
list(APPEND LDFLAGS -lstdc++)
-set(RUN_OPTIONS -f test -o -v -s kcc ${CMAKE_CURRENT_SOURCE_DIR}/inputs/f3.k ${CMAKE_CURRENT_SOURCE_DIR}/inputs/f2.k ${CMAKE_CURRENT_SOURCE_DIR}/inputs/f1.k)
-set(WORKDIR ${CMAKE_CURRENT_BINARY_DIR})
+set(RUN_OPTIONS -f test -o -v -s kcc inputs/f3.k inputs/f2.k inputs/f1.k)
set(HASH_PROGRAM_OUTPUT 1)
llvm_multisource(kc)
+llvm_test_data(kc inputs/f3.k inputs/f2.k inputs/f1.k)