aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CINT2000/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
committerMatthias Braun <matze@braunis.de>2018-08-23 22:34:14 +0000
commit81930acd88c60992449cd29417fa29ef6ca480a5 (patch)
tree538eca0d0a20bca95dcbd9298c007b4145914463 /External/SPEC/CINT2000/CMakeLists.txt
parenta1fbbc9edcfb0988e0e25171f6bc5bd67f43430c (diff)
cmake: Explicitely specify benchmark data
Explicitely declare what files are used as inputs for the benchmarks. This changes the benchmarks to: - Symlink (or copy) the related input files next to the binary into the build folder. - Set the working directory of the benchmark to be the folder of the executable. - Having the data next to the binary also reduces the amount of absolute paths in the test files. - Contains some smaller cleanups for SPEC95/2000/2006 files while adapting to the new data copying style. With this change in place you do not need the test-suite source repository anymore to run the benchmarks. This is an important step towards having a test-suite that can be cross-compiled on a host, then copied onto a device and ran there without having a shared filesystem like NFS setup. Differential Revision: https://reviews.llvm.org/D50209 git-svn-id: https://llvm.org/svn/llvm-project/test-suite/trunk@340582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'External/SPEC/CINT2000/CMakeLists.txt')
-rw-r--r--External/SPEC/CINT2000/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/External/SPEC/CINT2000/CMakeLists.txt b/External/SPEC/CINT2000/CMakeLists.txt
index cf88745c..8454ea95 100644
--- a/External/SPEC/CINT2000/CMakeLists.txt
+++ b/External/SPEC/CINT2000/CMakeLists.txt
@@ -2,7 +2,6 @@ include(${CMAKE_SOURCE_DIR}/External/SPEC/SpecCPU2000.cmake)
if(TEST_SUITE_SPEC2000_ROOT)
macro(cint2000_subdir BENCHMARK)
set(BENCHMARK_DIR ${TEST_SUITE_SPEC2000_ROOT}/benchspec/CINT2000/${BENCHMARK})
- set(PROG ${BENCHMARK})
file(GLOB Source ${BENCHMARK_DIR}/src/*.c ${BENCHMARK_DIR}/src/*.cpp)
add_subdirectory(${BENCHMARK})
endmacro()