aboutsummaryrefslogtreecommitdiff
path: root/rc3/libomptarget/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'rc3/libomptarget/test/CMakeLists.txt')
-rw-r--r--rc3/libomptarget/test/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/rc3/libomptarget/test/CMakeLists.txt b/rc3/libomptarget/test/CMakeLists.txt
new file mode 100644
index 0000000..5950c77
--- /dev/null
+++ b/rc3/libomptarget/test/CMakeLists.txt
@@ -0,0 +1,19 @@
+# CMakeLists.txt file for unit testing OpenMP offloading runtime library.
+if(NOT OPENMP_TEST_COMPILER_ID STREQUAL "Clang" OR
+ OPENMP_TEST_COMPILER_VERSION VERSION_LESS 6.0.0)
+ libomptarget_say("Can only test with Clang compiler in version 6.0.0 or later.")
+ libomptarget_warning_say("The check-libomptarget target will not be available!")
+ return()
+endif()
+
+if(LIBOMPTARGET_CMAKE_BUILD_TYPE MATCHES debug)
+ set(LIBOMPTARGET_DEBUG True)
+else()
+ set(LIBOMPTARGET_DEBUG False)
+endif()
+
+add_openmp_testsuite(check-libomptarget "Running libomptarget tests" ${CMAKE_CURRENT_BINARY_DIR} DEPENDS omptarget omp)
+
+# Configure the lit.site.cfg.in file
+set(AUTO_GEN_COMMENT "## Autogenerated by libomptarget configuration.\n# Do not edit!")
+configure_file(lit.site.cfg.in lit.site.cfg @ONLY)