aboutsummaryrefslogtreecommitdiff
path: root/final/libomptarget/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Stellard <tstellar@redhat.com>2019-07-19 14:14:12 +0000
committerTom Stellard <tstellar@redhat.com>2019-07-19 14:14:12 +0000
commitc9e7fc8c97382d61565f7ed180e4ea1cc8895b95 (patch)
tree49e96067e292b878b898418e8e34d39b292ecc9d /final/libomptarget/src/CMakeLists.txt
parentfbb805289dbc14ab68a145e44cc092a118dc6c3f (diff)
Creating release candidate final from release_801 branchsvn-tags/RELEASE_801
git-svn-id: https://llvm.org/svn/llvm-project/openmp/tags/RELEASE_801@366581 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'final/libomptarget/src/CMakeLists.txt')
-rw-r--r--final/libomptarget/src/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/final/libomptarget/src/CMakeLists.txt b/final/libomptarget/src/CMakeLists.txt
new file mode 100644
index 0000000..8e552d4
--- /dev/null
+++ b/final/libomptarget/src/CMakeLists.txt
@@ -0,0 +1,32 @@
+##===----------------------------------------------------------------------===##
+#
+# The LLVM Compiler Infrastructure
+#
+# This file is dual licensed under the MIT and the University of Illinois Open
+# Source Licenses. See LICENSE.txt for details.
+#
+##===----------------------------------------------------------------------===##
+#
+# Build offloading library libomptarget.so.
+#
+##===----------------------------------------------------------------------===##
+
+libomptarget_say("Building offloading runtime library libomptarget.")
+
+set(src_files
+ api.cpp
+ device.cpp
+ interface.cpp
+ rtl.cpp
+ omptarget.cpp
+)
+
+# Build libomptarget library with libdl dependency.
+add_library(omptarget SHARED ${src_files})
+target_link_libraries(omptarget
+ ${CMAKE_DL_LIBS}
+ "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exports")
+
+# Install libomptarget under the lib destination folder.
+install(TARGETS omptarget LIBRARY COMPONENT omptarget
+ DESTINATION "${OPENMP_INSTALL_LIBDIR}")