aboutsummaryrefslogtreecommitdiff
path: root/final/libomptarget/plugins/x86_64/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Stellard <tstellar@redhat.com>2019-04-11 23:41:27 +0000
committerTom Stellard <tstellar@redhat.com>2019-04-11 23:41:27 +0000
commit0c48ee0c90739da26986252ab5147810351eeff3 (patch)
treec4688322ef6ff3153683eab622de31ef851da282 /final/libomptarget/plugins/x86_64/CMakeLists.txt
parente82e2d89e6770bb05a0eec2db8f30058228d7ac6 (diff)
Creating release candidate final from release_710 branchsvn-tags/RELEASE_710
git-svn-id: https://llvm.org/svn/llvm-project/openmp/tags/RELEASE_710@358242 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'final/libomptarget/plugins/x86_64/CMakeLists.txt')
-rw-r--r--final/libomptarget/plugins/x86_64/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/final/libomptarget/plugins/x86_64/CMakeLists.txt b/final/libomptarget/plugins/x86_64/CMakeLists.txt
new file mode 100644
index 0000000..bdd5bba
--- /dev/null
+++ b/final/libomptarget/plugins/x86_64/CMakeLists.txt
@@ -0,0 +1,18 @@
+##===----------------------------------------------------------------------===##
+#
+# The LLVM Compiler Infrastructure
+#
+# This file is dual licensed under the MIT and the University of Illinois Open
+# Source Licenses. See LICENSE.txt for details.
+#
+##===----------------------------------------------------------------------===##
+#
+# Build a plugin for a x86_64 machine if available.
+#
+##===----------------------------------------------------------------------===##
+
+if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+ build_generic_elf64("x86_64" "x86_64" "x86_64" "x86_64-pc-linux-gnu" "62")
+else()
+ libomptarget_say("Not building x86_64 offloading plugin: machine not found in the system.")
+endif() \ No newline at end of file