aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40ee6cc..23b38f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,9 @@ then
DEJAGNU="/dev/null"
fi
AC_SUBST(DEJAGNU)
-dnl Makefile.am arranges for DEJAGNU to be exported in the environment.
+
+# See what branch we're in
+BRANCH=$(cd ${srcdir} && git branch | grep '^\*' | cut -d ' ' -f 2)
+AC_SUBST(BRANCH)
AC_OUTPUT([Makefile])