aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Rondini <diego.ml@zoho.com>2014-02-05 09:44:57 +0100
committerEric Bénard <eric@eukrea.com>2014-02-05 10:05:59 +0100
commit256f77109df1d8d07130e76d27812e1cd25d1ec7 (patch)
tree189b26743d6186fe7f48b347ebfab62cdff5a20f
parent748727cd8e854558aa03d9a72908c921205502de (diff)
chromium: Fix build with nss 3.15
Meta-browser commit 4b7a82273a85802070441e9c510e0891acc482fa broke Chromium build because removal of meta-browser nss 3.13.3 forced build against OE-Core 3.15.1, which is not supported out of the box by Chromium 29. This commit backports this patch: https://src.chromium.org/viewvc/chrome/trunk/src/net/third_party/nss/ssl/bodge/secitem_array.c?r1=206184&r2=206183&pathrev=206184&diff_format=u Upstream-Status: Backport of SVN REV 206184 Signed-off-by: Diego Rondini <diego.ml@zoho.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes-browser/chromium/chromium-29.0.1518.2/secitem_array.patch26
-rw-r--r--recipes-browser/chromium/chromium_29.0.1518.2.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-browser/chromium/chromium-29.0.1518.2/secitem_array.patch b/recipes-browser/chromium/chromium-29.0.1518.2/secitem_array.patch
new file mode 100644
index 0000000..3537952
--- /dev/null
+++ b/recipes-browser/chromium/chromium-29.0.1518.2/secitem_array.patch
@@ -0,0 +1,26 @@
+--- trunk/src/net/third_party/nss/ssl/bodge/secitem_array.c 2013/06/13 22:43:39 206183
++++ trunk/src/net/third_party/nss/ssl/bodge/secitem_array.c 2013/06/13 22:44:52 206184
+@@ -6,6 +6,7 @@
+ * Support routines for SECItemArray data structure.
+ */
+
++#include "nssutil.h"
+ #include "seccomon.h"
+ #include "secitem.h"
+ #include "secerr.h"
+@@ -13,10 +14,15 @@
+
+ typedef struct SECItemArrayStr SECItemArray;
+
++#define NSSUTIL_VERSION_NUM \
++ (NSSUTIL_VMAJOR * 10000 + NSSUTIL_VMINOR * 100 + NSSUTIL_VPATCH)
++#if NSSUTIL_VERSION_NUM < 31500
++// Added in NSS 3.15.
+ struct SECItemArrayStr {
+ SECItem *items;
+ unsigned int len;
+ };
++#endif
+
+ SECItemArray *
+ SECITEM_AllocArray(PLArenaPool *arena, SECItemArray *array, unsigned int len)
diff --git a/recipes-browser/chromium/chromium_29.0.1518.2.bb b/recipes-browser/chromium/chromium_29.0.1518.2.bb
index 4ebb254..1c62f1e 100644
--- a/recipes-browser/chromium/chromium_29.0.1518.2.bb
+++ b/recipes-browser/chromium/chromium_29.0.1518.2.bb
@@ -11,6 +11,7 @@ SRC_URI = "\
file://google-chrome.desktop \
file://uninitialised-warning.patch \
file://001-atk_focus_tracker_notify_deprecated_since_ATK_2_9_4.patch \
+ file://secitem_array.patch;striplevel=2 \
"
SRC_URI[md5sum] = "2480c3fd109ef000575629acb8a906ca"
SRC_URI[sha256sum] = "7f08624f7d9bd120de0043da7ee09985ae6b6990d22d8c1b1f7c66fd4ed681a1"