summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2018-06-27 12:46:38 -0500
committerAnders Roxell <anders.roxell@linaro.org>2018-07-25 18:23:45 +0200
commit28d4feec506f74f78f24e46c796a00078d6f5d3b (patch)
tree1d1bfbfde1b985b1536ba403ba091cb19d9f4701
parent9d4f4e3808a05070a5b3493d4f5f2bf138a367a8 (diff)
bpftool: import bpftool from meta-oesumo-bump
As of 27/06/2018. Which basically brings the following commit into meta-backports for sumo: 00d5219d6515 ("bpftool: add new recipe") Change-Id: If90fcc8ef4298bc1ddd88c131c49ea9b238b1850 Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
-rw-r--r--openembedded-layer/recipes-kernel/bpftool/bpftool.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/bpftool/bpftool.bb b/openembedded-layer/recipes-kernel/bpftool/bpftool.bb
new file mode 100644
index 0000000..fd0653a
--- /dev/null
+++ b/openembedded-layer/recipes-kernel/bpftool/bpftool.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Inspect and manipulate eBPF programs and maps"
+DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
+of eBPF programs and maps."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = "binutils elfutils"
+PROVIDES = "virtual/bpftool"
+
+inherit bash-completion kernelsrc kernel-arch
+
+do_populate_lic[depends] += "virtual/kernel:do_patch"
+
+EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+python do_package_prepend() {
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
+}
+
+B = "${WORKDIR}/${BPN}-${PV}"