aboutsummaryrefslogtreecommitdiff
path: root/recipes-devtools/gcc/gcc-cross_4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/gcc/gcc-cross_4.7.bb')
-rw-r--r--recipes-devtools/gcc/gcc-cross_4.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-cross_4.7.bb b/recipes-devtools/gcc/gcc-cross_4.7.bb
new file mode 100644
index 00000000..6d4b5b6f
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-cross_4.7.bb
@@ -0,0 +1,19 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require recipes-devtools/gcc/gcc-cross4.inc
+
+# The gcc-cross.inc pulls in gcc-package-cross.inc without specifying the
+# complete path in the require directive. This hack ensures bitbake is
+# pulling in the gcc-package-cross.inc from the meta-linaro layer.
+require gcc-package-cross.inc
+
+EXTRA_OECONF += "--disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+ --with-system-zlib "
+
+EXTRA_OECONF_PATHS = " \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"