aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb')
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb b/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb
new file mode 100644
index 00000000..79a08ee5
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb
@@ -0,0 +1,18 @@
+require linux-linaro.inc
+
+SRC_URI = " \
+ git://git.kernel.org/pub/scm/linux/kernel/git/maz/arm-platforms.git;branch=kvm-arm64/kvm;name=kernel \
+ git://git.linaro.org/arm/models/boot-wrapper-aarch64.git;branch=master;name=bootwrapper;destsuffix=bootwrapper \
+"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = " file://kvm-config"
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ ARCH=arm64 make defconfig
+ cat ../kvm-config >> .config
+ ARCH=arm64 make oldconfig
+
+}