aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra/idlestat/files/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra/idlestat/files/Makefile.patch')
-rw-r--r--meta-linaro/recipes-extra/idlestat/files/Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/idlestat/files/Makefile.patch b/meta-linaro/recipes-extra/idlestat/files/Makefile.patch
new file mode 100644
index 00000000..ef34babe
--- /dev/null
+++ b/meta-linaro/recipes-extra/idlestat/files/Makefile.patch
@@ -0,0 +1,17 @@
+Index: idlestat-0.5/Makefile
+===================================================================
+--- idlestat-0.5.orig/Makefile
++++ idlestat-0.5/Makefile
+@@ -38,10 +38,10 @@ OBJS = idlestat.o topology.o trace.o uti
+ default: idlestat
+
+ %.o: %.c
+- $(CROSS_COMPILE)$(CC) -c -o $@ $< $(CFLAGS)
++ $(CROSS_COMPILE)$(CC) -c $(CPPFLAGS) -o $@ $< $(CFLAGS)
+
+ idlestat: $(OBJS)
+- $(CROSS_COMPILE)$(CC) $(CFLAGS) $(OBJS) -o $@
++ $(CROSS_COMPILE)$(CC) $(CFLAGS) $(OBJS) -o $@ $(LDFLAGS)
+
+ install: idlestat idlestat.1
+ install -D -t /usr/local/bin idlestat