aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro-toolchain')
-rw-r--r--meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb2
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
index 63f03833..485b4a2c 100644
--- a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
+++ b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
@@ -104,7 +104,7 @@ FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-${PV}', '${FILE_DIRN
python __anonymous () {
import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))
diff --git a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
index 28ab4d78..8b207689 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
@@ -410,7 +410,7 @@ python () {
if not d.getVar("ELT_VER_MAIN"):
raise bb.parse.SkipPackage("External Linaro toolchain not configured (ELT_VER_MAIN not set).")
import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))