aboutsummaryrefslogtreecommitdiff
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf11
1 files changed, 10 insertions, 1 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 060e2b02..7f869dd1 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,3 +1,12 @@
BBPATH .= ":${LAYERDIR}"
BBFILES .= "${LAYERDIR}/recipes-*/*.bb \
- ${LAYERDIR}/recipes-*/*.bbappend"
+ ${LAYERDIR}/recipes-*/*.bbappend \
+ ${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "linaro"
+BBFILE_PATTERN_linaro := "^${LAYERDIR}/"
+BBFILE_PRIORITY_linaro = "5"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-linaro"
+PREFERRED_PROVIDER_kernel-base = "linux-linaro"