aboutsummaryrefslogtreecommitdiff
path: root/meta-optee
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2016-06-27 17:49:13 +0300
committerFathi Boudra <fathi.boudra@linaro.org>2016-06-28 14:37:00 +0300
commit8e57986f9ea50afc9c834aa208422e9a124a5c4d (patch)
treef49ee4421d5a0a854176e6c769b00bb8b70acd0e /meta-optee
parentccd2279d52f17b821eba14c5aba81d098bfe4a42 (diff)
optee-os: create optee directory only if it is armv7
optee directory under $DEPLOYDIR has content only if the architecture is ARMv7. Otherwise, it's empty. Create the directory only when we need to fill it. Change-Id: Ie150007913658cb36038fc916743b0b0ca6b859e Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-optee')
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index daf7428e..2828476c 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -58,9 +58,8 @@ do_deploy() {
long_srvrev=${SRCREV}
short_srvrev=$(echo $long_srvrev | awk '{ string=substr($0, 1, 8); print string; }' )
OPTEE_CORE_SUFFIX="${MACHINE}-$short_srvrev"
- install -d ${DEPLOYDIR}/optee
- if [ "${is_armv7}" = "1" ];
- then
+ if [ "${is_armv7}" = "1" ]; then
+ install -d ${DEPLOYDIR}/optee
for f in ${D}/lib/firmware/*; do
filename=$(basename "$f")
extension="${filename##*.}"