aboutsummaryrefslogtreecommitdiff
path: root/meta-optee
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2016-06-13 11:04:17 +0200
committerKoen Kooi <koen.kooi@linaro.org>2016-06-23 07:35:36 +0200
commit39177aac4c05a87fc80f85515d4be3ef93da3074 (patch)
tree40417298d244d9416c10ee306973b39eba2a2500 /meta-optee
parenta5299b0bc6721f584a56f2696beb19db9e1974f1 (diff)
optee-os: update to latest git
Change-Id: I083c522c8018ee062c49c79ab2705f065f11d682 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-optee')
-rw-r--r--meta-optee/recipes-security/optee/optee-os/b9447a136558a48a40928493dd6f18aae2701e8b.patch39
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb11
2 files changed, 47 insertions, 3 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os/b9447a136558a48a40928493dd6f18aae2701e8b.patch b/meta-optee/recipes-security/optee/optee-os/b9447a136558a48a40928493dd6f18aae2701e8b.patch
new file mode 100644
index 00000000..b85308fc
--- /dev/null
+++ b/meta-optee/recipes-security/optee/optee-os/b9447a136558a48a40928493dd6f18aae2701e8b.patch
@@ -0,0 +1,39 @@
+From b9447a136558a48a40928493dd6f18aae2701e8b Mon Sep 17 00:00:00 2001
+From: Jerome Forissier <jerome.forissier@linaro.org>
+Date: Mon, 13 Jun 2016 08:54:56 +0200
+Subject: [PATCH] tui: Add __maybe_unused
+
+Parameter 'msg' is not used when CFG_TEE_TA_LOG_LEVEL=0, so add
+__maybe_unused.
+
+Fixes https://github.com/OP-TEE/optee_os/issues/848.
+
+Signed-off-by: Jerome Forissier <jerome.forissier@linaro.org>
+Reviewed-by: Joakim Bech <joakim.bech@linaro.org>
+Tested-by: Joakim Bech <joakim.bech@linaro.org> (QEMU, HiKey 32/64)
+Reviewed-by: Jens Wiklander <jens.wiklander@linaro.org>
+---
+ lib/libutee/tui/image_png.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/lib/libutee/tui/image_png.c b/lib/libutee/tui/image_png.c
+index 7399c98..950cfed 100644
+--- a/lib/libutee/tui/image_png.c
++++ b/lib/libutee/tui/image_png.c
+@@ -25,6 +25,7 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
++#include <compiler.h>
+ #include <stdlib.h>
+ #include <png.h>
+ #include <tee_api.h>
+@@ -39,7 +40,7 @@ struct image_work {
+ const uint8_t *end_data;
+ };
+
+-static void error_cb(png_structp png_ptr, png_const_charp msg)
++static void error_cb(png_structp png_ptr, png_const_charp msg __maybe_unused)
+ {
+ struct image_work *w;
+
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index cb2c8355..bbdd21d4 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -6,13 +6,15 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=69663ab153298557a59c67a60a743e5b"
PV="2.0.0+git${SRCPV}"
-DEPENDS = "python-pycrypto-native"
+DEPENDS = "python-wand-native python-pycrypto-native"
inherit deploy pythonnative
-SRCREV = "eb00c7b99f79964c8d08c88e94ab99f12c504ff9"
+SRCREV = "3f19eae1f645530820ade9e421df95cf16e38f85"
SRC_URI = "git://github.com/OP-TEE/optee_os.git \
- file://0001-allow-setting-sysroot-for-libgcc-lookup.patch "
+ file://0001-allow-setting-sysroot-for-libgcc-lookup.patch \
+ file://b9447a136558a48a40928493dd6f18aae2701e8b.patch \
+ "
S = "${WORKDIR}/git"
@@ -27,6 +29,9 @@ EXTRA_OEMAKE = "PLATFORM=${OPTEEMACHINE} CFG_ARM64_core=y \
LIBGCC_LOCATE_CFLAGS=--sysroot=${STAGING_DIR_HOST} \
"
+# Needed so that python-wand can find the installed imagemagick install.
+export MAGICK_HOME="${STAGING_DIR_NATIVE}${prefix}"
+
OPTEE_ARCH_armv7a = "arm32"
OPTEE_ARCH_aarch64 = "arm64"