aboutsummaryrefslogtreecommitdiff
path: root/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2016-05-20 09:45:36 +0200
committerKoen Kooi <koen.kooi@linaro.org>2016-06-23 07:35:36 +0200
commitb7baae4a75428a3ec93c9577481821c190d57356 (patch)
treeeb3c011e856f83cfd8defd4294f25343fabfe901 /meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
parent976ba17e667667194fbdc3369c85eb79ecd6d037 (diff)
python-pycrypto: import from meta-security
Change-Id: I7970f089b21950c159161985a9d10f7c8d2260a6 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb')
-rw-r--r--meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 00000000..1477418d
--- /dev/null
+++ b/meta-optee/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Cryptographic modules for Python."
+HOMEPAGE = "http://www.pycrypto.org/"
+SECTION = "devel/python"
+LICENSE = "PSFv2"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
+
+SRCNAME = "pycrypto"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://cross-compiling.patch"
+
+SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
+SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit autotools autotools-brokensep distutils
+
+DEPENDS += " gmp"
+
+export STAGING_INCDIR
+export STAGING_LIBDIR
+export BUILD_SYS
+export HOST_SYS
+
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils_do_install
+}
+
+BBCLASSEXTEND = "native"