aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-02-20 06:28:17 +0000
committerLinaro Code Review <review@review.linaro.org>2015-02-20 06:28:17 +0000
commit549ec84eaf568035e6e16a36e1c60d7fdcaaf8a0 (patch)
tree4d116aa52bf02bed90f00728020df13d56172743 /meta-linaro
parente6e66d3c93c571e82635ac1e5d83fffbcaaf144f (diff)
parent465520cefa0c9bccdb7a8cdd039b90f5704624fd (diff)
Merge "perf bbappend: move to 3.18.5"
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-arm64-build-error.patch42
-rw-r--r--meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-build-breakage-on-arm64-targets.patch45
-rw-r--r--meta-linaro/recipes-kernel/perf/perf.bbappend13
3 files changed, 5 insertions, 95 deletions
diff --git a/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-arm64-build-error.patch b/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-arm64-build-error.patch
deleted file mode 100644
index 4a4da97c..00000000
--- a/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-arm64-build-error.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 7d885749b6de2c9a1168d566e2380207b9177108 Mon Sep 17 00:00:00 2001
-From: Mark Salter <msalter@redhat.com>
-Date: Fri, 25 Jul 2014 18:02:46 -0400
-Subject: [PATCH] perf tools: Fix arm64 build error
-
-I'm seeing the following build error on arm64:
-
- In file included from util/event.c:3:0:
- util/event.h:95:17: error: 'PERF_REGS_MAX' undeclared here (not in a function)
- u64 cache_regs[PERF_REGS_MAX];
- ^
-
-This patch adds a PERF_REGS_MAX definition for arm64.
-
-Signed-off-by: Mark Salter <msalter@redhat.com>
-Acked-by: Jean Pihet <jean.pihet@linaro.org>
-Cc: Ingo Molnar <mingo@redhat.com>
-Cc: Jean Pihet <jean.pihet@linaro.org>
-Cc: Paul Mackerras <paulus@samba.org>
-Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
-Link: http://lkml.kernel.org/r/1406325766-8085-1-git-send-email-msalter@redhat.com
-Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
----
- tools/perf/arch/arm64/include/perf_regs.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/tools/perf/arch/arm64/include/perf_regs.h b/tools/perf/arch/arm64/include/perf_regs.h
-index e9441b9..1d3f39c 100644
---- a/tools/perf/arch/arm64/include/perf_regs.h
-+++ b/tools/perf/arch/arm64/include/perf_regs.h
-@@ -6,6 +6,8 @@
- #include <asm/perf_regs.h>
-
- #define PERF_REGS_MASK ((1ULL << PERF_REG_ARM64_MAX) - 1)
-+#define PERF_REGS_MAX PERF_REG_ARM64_MAX
-+
- #define PERF_REG_IP PERF_REG_ARM64_PC
- #define PERF_REG_SP PERF_REG_ARM64_SP
-
---
-2.1.3
-
diff --git a/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-build-breakage-on-arm64-targets.patch b/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-build-breakage-on-arm64-targets.patch
deleted file mode 100644
index cb039460..00000000
--- a/meta-linaro/recipes-kernel/perf/files/0001-perf-tools-Fix-build-breakage-on-arm64-targets.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 660d13296bbbe79635d1d9d700080b88061faffb Mon Sep 17 00:00:00 2001
-From: Will Deacon <will.deacon@arm.com>
-Date: Tue, 30 Sep 2014 12:27:12 +0100
-Subject: [PATCH] perf tools: Fix build breakage on arm64 targets
-
-Attempting to build the perf tool for an arm64 target results in the
-following failure:
-
- arch/arm64/util/unwind-libunwind.c: In function 'libunwind__arch_reg_id':
- arch/arm64/util/unwind-libunwind.c:77:3: error: implicit declaration of function 'pr_err'
- pr_err("unwind: invalid reg id %d\n", regnum);
- ^
- arch/arm64/util/unwind-libunwind.c:77:3: error: nested extern declaration of 'pr_err'
-
-This is due to commit 84f5d36f4866 ("perf tools: Move pr_* debug macros
-into debug object") moving the pr_* macros into a new header file, but
-failing to update architectures other than x86.
-
-This patch adds the missing include, and fixes the build again.
-
-Signed-off-by: Will Deacon <will.deacon@arm.com>
-Cc: Jean Pihet <jean.pihet@linaro.org>
-Cc: Jiri Olsa <jolsa@kernel.org>
-Cc: linux-arm-kernel@lists.infradead.org
-Link: http://lkml.kernel.org/r/1412076432-22045-1-git-send-email-will.deacon@arm.com
-Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
----
- tools/perf/arch/arm64/util/unwind-libunwind.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tools/perf/arch/arm64/util/unwind-libunwind.c b/tools/perf/arch/arm64/util/unwind-libunwind.c
-index 436ee43..a87afa9 100644
---- a/tools/perf/arch/arm64/util/unwind-libunwind.c
-+++ b/tools/perf/arch/arm64/util/unwind-libunwind.c
-@@ -3,6 +3,7 @@
- #include <libunwind.h>
- #include "perf_regs.h"
- #include "../../util/unwind.h"
-+#include "../../util/debug.h"
-
- int libunwind__arch_reg_id(int regnum)
- {
---
-2.1.3
-
diff --git a/meta-linaro/recipes-kernel/perf/perf.bbappend b/meta-linaro/recipes-kernel/perf/perf.bbappend
index 0b52f7c3..7bf446ae 100644
--- a/meta-linaro/recipes-kernel/perf/perf.bbappend
+++ b/meta-linaro/recipes-kernel/perf/perf.bbappend
@@ -1,19 +1,16 @@
LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-PV = "3.17"
+PV = "3.18.5"
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI = "${DEBIAN_MIRROR}/main/l/linux-tools/linux-tools_3.17.orig.tar.xz \
- file://0001-perf-tools-Fix-arm64-build-error.patch \
- file://0001-perf-tools-Fix-build-breakage-on-arm64-targets.patch \
-"
+SRC_URI = "${DEBIAN_MIRROR}/main/l/linux-tools/linux-tools_3.18.5.orig.tar.xz"
-SRC_URI[md5sum] = "6c78f25c86761a60b89235e12bc109a8"
-SRC_URI[sha256sum] = "51162320841053fcf06070b6d5a6d984fb4c429e3ba3dc6d4eec021d374b926f"
+SRC_URI[md5sum] = "c9ee8f5c1f88e562f1c1d6997c442c7f"
+SRC_URI[sha256sum] = "bf79397874cc211e81eed47e2c2591632ba7b03d3de73aea867f2a78917b9720"
S = "${WORKDIR}/linux-tools-${PV}"
-B = "${WORKDIR}/linux-tools-${PV}"
+B = "${WORKDIR}/linux-tools-${PV}-build"
do_compile_prepend() {
mkdir -p ${S}/include/generated