aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-03-25 12:13:40 +0100
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-03-25 12:13:40 +0100
commit8acf869a95f054644cd89b80b52af96032d1544a (patch)
tree2ff3a1c4ec5383f50ff1bf6015345ef9c3bfc13c /meta-linaro
parent356a770a828b4ede424b8b6a6fa66455b67062ad (diff)
powertop: merge all changes sent to OE
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-extra/powertop/powertop_2.3.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/powertop/powertop_2.3.bb b/meta-linaro/recipes-extra/powertop/powertop_2.3.bb
index c289ac6e..d21f00d6 100644
--- a/meta-linaro/recipes-extra/powertop/powertop_2.3.bb
+++ b/meta-linaro/recipes-extra/powertop/powertop_2.3.bb
@@ -1,5 +1,7 @@
+SUMMARY = "Power usage tool"
DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
HOMEPAGE = "http://01.org/powertop/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
DEPENDS = "ncurses virtual/gettext libnl pciutils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
@@ -10,3 +12,19 @@ SRC_URI[md5sum] = "dc03608f20e56cdc99d121a6191556f6"
SRC_URI[sha256sum] = "b8c1add69afee28c77dca56fdcedb4a46820f3a71c86aae7891b0c5c595cd744"
inherit autotools
+
+# we need to explicitly link with libintl in uClibc systems
+LDFLAGS += "${EXTRA_LDFLAGS}"
+EXTRA_LDFLAGS_libc-uclibc = "-lintl"
+
+# we do not want libncursesw if we can
+do_configure_prepend() {
+ # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
+ sed -i -e "s/ncursesw//g" ${S}/configure.ac
+}
+
+inherit update-alternatives
+ALTERNATIVE_${PN} = "powertop"
+ALTERNATIVE_TARGET[powertop] = "${bindir}/powertop"
+ALTERNATIVE_LINK_NAME[powertop] = "${base_bindir}/powertop"
+ALTERNATIVE_PRIORITY = "100"