aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2017-02-17 09:07:54 +0100
committerKoen Kooi <koen.kooi@linaro.org>2017-02-17 09:39:21 +0100
commit55ab8352865d01f5345802399500e7da1de2c554 (patch)
tree19ea84185ae371b7ef529abe891c362fe13ceac6 /meta-linaro/recipes-kernel
parentd4639deb43bb6c62ac06aaf951245edc9b9f410e (diff)
gator: update to 5.22 and fix build
Change-Id: Iaec2828b69d534c76ca4705f87cbc41a5b4a2898 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index d3b97241..83543008 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -4,8 +4,8 @@ DESCRIPTION = "Target-side daemon gathering data for ARM Streamline Performance
LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://driver/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRCREV = "f0ddf6b40e42579f2275974620399fb3406d0c18"
-PV = "5.21.1+git${SRCPV}"
+SRCREV = "7ca6004c0b05138c49b9b21e0045487f55a60ab6"
+PV = "5.22+git${SRCPV}"
SRC_URI = "git://git.linaro.org/arm/ds5/gator.git;protocol=http;branch=linaro \
file://gator.init"
@@ -14,7 +14,12 @@ S = "${WORKDIR}/git"
inherit update-rc.d
-EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
+# Since this is c++ code we need to both compile and link with CXX
+#| PerfSource.o: In function `PerfSource::~PerfSource()':
+#| /usr/src/debug/gator/5.22+gitAUTOINC+7ca6004c0b-r0/git/daemon/PerfSource.cpp:128: undefined reference to `operator delete(void*, unsigned long)'
+CC = "${CXX}"
+
+EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\"${sysconfdir}\"' \
'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti'"