aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-08-21 12:42:38 +0300
committerRiku Voipio <riku.voipio@linaro.org>2013-08-26 13:58:23 +0300
commitb6e5d7c7326f8cb73e9154abca9f19dd8e33db31 (patch)
tree9dbcae1083bd8e0d6de1db9c9374de9b851db642 /meta-linaro/recipes-kernel
parent82fa48fb82e94a908f8be74ebddcd85a6ca306e9 (diff)
Move linux-linaro to meta-linaro
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/linux/files/kvm-config28
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb18
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro.inc63
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro_git.bb11
4 files changed, 120 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/linux/files/kvm-config b/meta-linaro/recipes-kernel/linux/files/kvm-config
new file mode 100644
index 00000000..2b64733a
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/files/kvm-config
@@ -0,0 +1,28 @@
+CONFIG_BALLOON_COMPACTION=y
+CONFIG_VIRTIO_BLK=y
+CONFIG_VIRTIO_NET=y
+CONFIG_VIRTIO_CONSOLE=y
+CONFIG_VIRTIO=y
+CONFIG_VIRTIO_BALLOON=y
+CONFIG_VIRTIO_MMIO=y
+CONFIG_VIRTIO_MMIO_CMDLINE_DEVICES=y
+CONFIG_VIRTUALIZATION=y
+CONFIG_HAVE_KVM_IRQCHIP=y
+CONFIG_KVM_ARM_HOST=y
+CONFIG_KVM_ARM_TIMER=y
+CONFIG_KVM_ARM_VGIC=y
+CONFIG_KVM_MMIO=y
+CONFIG_KVM=y
+CONFIG_BLK_DEV=y
+CONFIG_BLK_DEV_LOOP=y
+CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
+CONFIG_VIRTIO_BLK=y
+CONFIG_VIRTIO=y
+CONFIG_VIRTIO_MMIO=y
+CONFIG_REGULATOR=y
+CONFIG_REGULATOR_FIXED_VOLTAGE=y
+CONFIG_MMC=y
+CONFIG_MMC_ARMMMCI=y
+CONFIG_RTC_CLASS=y
+CONFIG_RTC_DRV_PL031=y
+
diff --git a/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb b/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb
new file mode 100644
index 00000000..79a08ee5
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linux-aarch64-kvm_git.bb
@@ -0,0 +1,18 @@
+require linux-linaro.inc
+
+SRC_URI = " \
+ git://git.kernel.org/pub/scm/linux/kernel/git/maz/arm-platforms.git;branch=kvm-arm64/kvm;name=kernel \
+ git://git.linaro.org/arm/models/boot-wrapper-aarch64.git;branch=master;name=bootwrapper;destsuffix=bootwrapper \
+"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRC_URI_append = " file://kvm-config"
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ ARCH=arm64 make defconfig
+ cat ../kvm-config >> .config
+ ARCH=arm64 make oldconfig
+
+}
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro.inc b/meta-linaro/recipes-kernel/linux/linux-linaro.inc
new file mode 100644
index 00000000..f444d05d
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "Linaro Kernel For Aarch64"
+SECTION = "kernel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+inherit kernel siteinfo
+
+PV = "3.10+git${SRCPV}"
+
+SRCREV_bootwrapper = "${AUTOREV}"
+SRCREV_kernel = "${AUTOREV}"
+SRCREV_FORMAT = "kernel"
+
+S = "${WORKDIR}/git"
+BW = "${WORKDIR}/bootwrapper"
+
+COMPATIBLE_HOST = "aarch64"
+KERNEL_IMAGETYPE = "Image"
+
+PACKAGES =+ "kernel-bootwrapper"
+FILES_kernel-bootwrapper = "/boot/img-foundation.axf"
+
+BOOTARGS_COMMON = "console=ttyAMA0 mem=2048M devtmpfs.mount=1 earlyprintk=pl011,0x1c090000 consolelog=9 rw"
+
+do_compile_append() {
+ CROSS=`echo $CC|sed -e s/gcc.*//`
+ install -m 0644 ${S}/arch/arm64/boot/Image ${BW}/
+ install -m 0644 ${S}/arch/arm64/boot/dts/*.dts* ${BW}/
+ cd ${BW}
+ make clean
+ make DTC=${S}/scripts/dtc/dtc \
+ FDT_SRC=foundation-v8.dts \
+ CROSS_COMPILE=$CROSS \
+ IMAGE=linux-system-foundation.axf \
+ BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda"'
+ make clean
+ make DTC=${S}/scripts/dtc/dtc \
+ FDT_SRC=foundation-v8.dts \
+ CROSS_COMPILE=$CROSS \
+ IMAGE=img-foundation.axf \
+ BOOTARGS='"${BOOTARGS_COMMON} root=/dev/vda2"'
+ make clean
+ make DTC=${S}/scripts/dtc/dtc \
+ FDT_SRC=rtsm_ve-aemv8a.dts \
+ CROSS_COMPILE=$CROSS \
+ IMAGE=linux-system-ve.axf \
+ BOOTARGS='"${BOOTARGS_COMMON} root=/dev/mmcblk0"'
+}
+
+do_install_append() {
+ install -m 0644 ${BW}/img-foundation.axf ${D}/boot/img-foundation.axf
+}
+
+do_deploy_append() {
+ install -d ${DEPLOYDIR}
+ install -m 0644 ${BW}/linux-system-ve.axf ${DEPLOYDIR}/linux-system-ve-${KERNEL_IMAGE_BASE_NAME}.axf
+ install -m 0644 ${BW}/linux-system-foundation.axf ${DEPLOYDIR}/linux-system-foundation-${KERNEL_IMAGE_BASE_NAME}.axf
+ install -m 0644 ${BW}/img-foundation.axf ${DEPLOYDIR}/img-foundation-${KERNEL_IMAGE_BASE_NAME}.axf
+ cd ${DEPLOYDIR}
+ ln -sf linux-system-ve-${KERNEL_IMAGE_BASE_NAME}.axf linux-system-ve.axf
+ ln -sf linux-system-foundation-${KERNEL_IMAGE_BASE_NAME}.axf linux-system-foundation.axf
+ ln -sf img-foundation-${KERNEL_IMAGE_BASE_NAME}.axf img-foundation.axf
+}
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro_git.bb b/meta-linaro/recipes-kernel/linux/linux-linaro_git.bb
new file mode 100644
index 00000000..6738d2ce
--- /dev/null
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro_git.bb
@@ -0,0 +1,11 @@
+require linux-linaro.inc
+
+SRC_URI = " \
+ git://git.linaro.org/kernel/linux-linaro-tracking.git;branch=linux-linaro;name=kernel \
+ git://git.linaro.org/arm/models/boot-wrapper-aarch64.git;branch=master;name=bootwrapper;destsuffix=bootwrapper \
+"
+
+do_configure_prepend() {
+ ARCH=arm64 scripts/kconfig/merge_config.sh -m linaro/configs/linaro-base.conf \
+ linaro/configs/vexpress64.conf linaro/configs/ubuntu-minimal.conf linaro/configs/distribution.conf
+}