aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
authorKevin Hao <kexin.hao@windriver.com>2014-12-31 13:58:17 +0800
committerKoen Kooi <koen.kooi@linaro.org>2015-01-08 10:49:42 +0100
commitd409c02e339533e360612672f84c2d9e59fcaf50 (patch)
tree86bcd02e836ddb17ef4014df362d3c7989e25989 /meta-linaro/recipes-kernel
parentc94519412e0da09d39e857c44f8d48d91a184ec8 (diff)
linux-linaro-aarch64: change to source directory before merging config files
We use the merge_config.sh to generate the final kernel config file, but this file only exist in the kernel source directory and so do for the config files. So we need to change to kernel source directory first. Change-Id: I35ffac62d00c08b962aee5013e41c0e1f7dba341 Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb b/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
index 6e181a77..6e027d39 100644
--- a/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
+++ b/meta-linaro/recipes-kernel/linux/linux-linaro-aarch64.bb
@@ -18,5 +18,7 @@ BOOTARGS_COMMON = "console=ttyAMA0 mem=2048M devtmpfs.mount=1 earlyprintk=pl011,
do_configure_prepend() {
. ../ubuntu-ci/configs/vexpress64.cfg
+ cd ${S}
ARCH=arm64 scripts/kconfig/merge_config.sh -m $linaro_base_config_frags $ubuntu_config_frag $board_config_frags
+ cd ${B}
}