aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2014-02-08 20:27:04 +0100
committerAnders Roxell <anders.roxell@linaro.org>2014-02-14 12:14:38 +0100
commit6597539d206c77694062b3016da3695785e6fc13 (patch)
tree9f89c7217f2da12da48c24daa0f1894a36136e0f /meta-linaro/recipes-extra
parentaf2a64f9b2a1f7484979b3883a3956994ce0cce0 (diff)
usecpu: add new recipe
Change-Id: I9225cd70f8e1ce5168d320d901e4254dfa2a7242 Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/usecpu/usecpu_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/usecpu/usecpu_git.bb b/meta-linaro/recipes-extra/usecpu/usecpu_git.bb
new file mode 100644
index 00000000..0d4dc991
--- /dev/null
+++ b/meta-linaro/recipes-extra/usecpu/usecpu_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Uses the CPU"
+DESCRIPTION = "This program uses the CPU on a System"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;endline=39;md5=c16edc6b3353707bb4789198c72f7e48"
+SRCREV = "e246c70aa6cac5df0e593ef3416380ff75a70dc0"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://git.linaro.org/people/anders.roxell/usecpu.git"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake use_cpu
+}
+
+do_install() {
+ install -D -p -m0755 use_cpu ${D}${bindir}/use_cpu
+}