aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-04-03 08:11:13 +0200
committerKoen Kooi <koen.kooi@linaro.org>2014-04-03 08:12:19 +0200
commit0285d7ea1d334eb6140758c7066a169f5d785b67 (patch)
treeea4523eb7d1d6599d7014f22471c3eae94d77404 /meta-linaro/recipes-extra
parent0de3d19afb03c80b85a3f6ddec8565763c15a3d4 (diff)
trinity: update to 1.3
This fixes a build error with V4L2 symbols and as a bonus has all the linaro patches applied upstream. Change-Id: I6842c06dcf2b8c7805da1e6616c92a29b6f66021 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch200
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch171
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch95
-rw-r--r--meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch389
-rw-r--r--meta-linaro/recipes-extra/trinity/trinity_1.3.bb (renamed from meta-linaro/recipes-extra/trinity/trinity_1.2.bb)8
5 files changed, 2 insertions, 861 deletions
diff --git a/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch b/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch
deleted file mode 100644
index 851a18e6..00000000
--- a/meta-linaro/recipes-extra/trinity/files/0001-scripts-TRINITY_PATH-defaults-to.patch
+++ /dev/null
@@ -1,200 +0,0 @@
-From 74d806c91ff7894d5c1cd8d736b87e02047c6799 Mon Sep 17 00:00:00 2001
-From: Anders Roxell <anders.roxell@linaro.org>
-Date: Tue, 8 Oct 2013 16:02:56 +0200
-Subject: [PATCH 1/3] scripts: TRINITY_PATH defaults to "."
-
-TRINITY_PATH may be changed in the enviroment
-
-Upstream-Status: Backport
-
-Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
----
- scripts/analyse-dumps.sh | 4 +++-
- scripts/clean-cores.sh | 4 +++-
- scripts/find.sh | 8 +++++---
- scripts/test-all-syscalls-parallel.sh | 6 ++++--
- scripts/test-all-syscalls-sequentially.sh | 8 +++++---
- scripts/test-multi.sh | 6 ++++--
- scripts/test-vm.sh | 4 +++-
- 7 files changed, 27 insertions(+), 13 deletions(-)
-
-diff --git a/scripts/analyse-dumps.sh b/scripts/analyse-dumps.sh
-index d55393c..bd45ea5 100755
---- a/scripts/analyse-dumps.sh
-+++ b/scripts/analyse-dumps.sh
-@@ -1,8 +1,10 @@
- #!/bin/sh
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- for core in $(find . -name "core.*")
- do
-- gdb -batch -n -ex 'bt' ./trinity $core > core.txt
-+ gdb -batch -n -ex 'bt' $TRINITY_PATH/trinity $core > core.txt
- SHA=$(cat core.txt| grep -v New\ LWP | sha1sum)
- cat core.txt > core-$SHA.txt
- rm -f core.txt
-diff --git a/scripts/clean-cores.sh b/scripts/clean-cores.sh
-index 821e06a..0b90be6 100755
---- a/scripts/clean-cores.sh
-+++ b/scripts/clean-cores.sh
-@@ -1,8 +1,10 @@
- #!/bin/sh
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- # remove old cores
- for i in `find . -name "core.*" -exec ls -l {} \; | grep -v "$(date +%b\ %e)" | awk '{ print $9 }'`; do rm -f $i; done
-
- # Remove corrupted cores
- find . -empty -name "core.*" -exec rm -f {} \;
--for i in $(file core.* | grep -v trinity | awk '{ print $1 }' | sed 's/://'); do rm -f $i; done
-+for i in $(file core.* | grep -v $TRINITY_PATH/trinity | awk '{ print $1 }' | sed 's/://'); do rm -f $i; done
-diff --git a/scripts/find.sh b/scripts/find.sh
-index 537160f..5528210 100755
---- a/scripts/find.sh
-+++ b/scripts/find.sh
-@@ -5,6 +5,8 @@
- # sendmsg that only occurred after connect was called.
- #
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- check_tainted()
- {
- if [ "$(cat /proc/sys/kernel/tainted)" != $TAINT ]; then
-@@ -27,18 +29,18 @@ while [ 1 ];
- do
-
-
--for sc in $(../trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
- do
- mkdir -p tmp.$i
- pushd tmp.$i
-
-- if [ ! -f ../../trinity ]; then
-+ if [ ! -f $TRINITY_PATH/trinity ]; then
- echo lost!
- pwd
- exit
- fi
-
-- ../../trinity -q -l off -n -c sendmsg -c $sc -C32 -N 999999
-+ $TRINITY_PATH/trinity -q -l off -n -c sendmsg -c $sc -C32 -N 999999
-
- popd
-
-diff --git a/scripts/test-all-syscalls-parallel.sh b/scripts/test-all-syscalls-parallel.sh
-index 861c156..c713cce 100755
---- a/scripts/test-all-syscalls-parallel.sh
-+++ b/scripts/test-all-syscalls-parallel.sh
-@@ -1,5 +1,7 @@
- #!/bin/bash
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- if [ ! -d tmp ]; then
- mkdir tmp
- fi
-@@ -8,9 +10,9 @@ cd tmp
-
- while [ 1 ];
- do
-- for syscall in $(../trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+ for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
- do
-- MALLOC_CHECK_=2 ../trinity -q -c $syscall -D &
-+ MALLOC_CHECK_=2 $TRINITY_PATH/trinity -q -c $syscall -D &
- done
- wait
- done
-diff --git a/scripts/test-all-syscalls-sequentially.sh b/scripts/test-all-syscalls-sequentially.sh
-index 85bcf71..6d79db4 100755
---- a/scripts/test-all-syscalls-sequentially.sh
-+++ b/scripts/test-all-syscalls-sequentially.sh
-@@ -3,6 +3,8 @@
- # This is a useful test to run occasionally, to see which syscalls are
- # causing trinity to segfault.
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- check_tainted()
- {
- if [ "$(cat /proc/sys/kernel/tainted)" != $TAINT ]; then
-@@ -19,18 +21,18 @@ TAINT=$(cat /proc/sys/kernel/tainted)
-
- while [ 1 ]
- do
--for syscall in $(./trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
- do
- chmod 755 tmp
- pushd tmp
-
-- if [ ! -f ../trinity ]; then
-+ if [ ! -f $TRINITY_PATH/trinity ]; then
- echo lost!
- pwd
- exit
- fi
-
-- MALLOC_CHECK_=2 ../trinity -q -c $syscall -N 99999 -l off -C 64
-+ MALLOC_CHECK_=2 $TRINITY_PATH/trinity -q -c $syscall -N 99999 -l off -C 64
- popd
-
- check_tainted
-diff --git a/scripts/test-multi.sh b/scripts/test-multi.sh
-index cad297c..33db834 100755
---- a/scripts/test-multi.sh
-+++ b/scripts/test-multi.sh
-@@ -1,5 +1,7 @@
- #!/bin/bash
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- check_tainted()
- {
- if [ "$(cat /proc/sys/kernel/tainted)" != $TAINT ]; then
-@@ -21,7 +23,7 @@ NR_PROCESSES=$(($NR_CPUS * 2))
-
- while [ 1 ];
- do
-- cp ../trinity .
-+ cp $TRINITY_PATH/trinity .
-
- for i in `seq 1 $NR_PROCESSES`
- do
-@@ -33,7 +35,7 @@ do
- mkdir -p tmp.$i
- pushd tmp.$i
-
-- if [ ! -f ../../trinity ]; then
-+ if [ ! -f $TRINITY_PATH/trinity ]; then
- echo lost!
- pwd
- exit
-diff --git a/scripts/test-vm.sh b/scripts/test-vm.sh
-index 4c472ca..6b75e8d 100755
---- a/scripts/test-vm.sh
-+++ b/scripts/test-vm.sh
-@@ -1,5 +1,7 @@
- #!/bin/bash
-
-+TRINITY_PATH=${TRINITY_PATH:-.}
-+
- if [ ! -d tmp ]; then
- mkdir tmp
- fi
-@@ -16,7 +18,7 @@ do
- cd tmp.$RND
- for i in `seq 1 $NR_PROCESSES`
- do
-- ../../trinity -q -g vm &
-+ $TRINITY_PATH/trinity -q -g vm &
- done
- wait
- cd ..
---
-1.8.1.2
-
diff --git a/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch b/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch
deleted file mode 100644
index a0c10956..00000000
--- a/meta-linaro/recipes-extra/trinity/files/0002-scripts-change-mkdir-tmp-to-mktemp.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-From 3146cc9a97c951669468d10dce1245d74a0b0c17 Mon Sep 17 00:00:00 2001
-From: Anders Roxell <anders.roxell@linaro.org>
-Date: Tue, 8 Oct 2013 16:45:08 +0200
-Subject: [PATCH 2/3] scripts: change mkdir tmp to mktemp
-
-Upstream-Status: Accepted
-
-Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
----
- scripts/find.sh | 10 ++++------
- scripts/test-all-syscalls-parallel.sh | 8 +++-----
- scripts/test-all-syscalls-sequentially.sh | 9 +++------
- scripts/test-multi.sh | 12 +++++-------
- scripts/test-vm.sh | 8 +++-----
- 5 files changed, 18 insertions(+), 29 deletions(-)
-
-diff --git a/scripts/find.sh b/scripts/find.sh
-index 5528210..3f10c58 100755
---- a/scripts/find.sh
-+++ b/scripts/find.sh
-@@ -6,6 +6,7 @@
- #
-
- TRINITY_PATH=${TRINITY_PATH:-.}
-+TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-
- check_tainted()
- {
-@@ -15,11 +16,8 @@ check_tainted()
- fi
- }
-
--if [ ! -d tmp ]; then
-- mkdir tmp
--fi
--chmod 755 tmp
--cd tmp
-+chmod 755 $TRINITY_TMP
-+cd $TRINITY_TMP
-
- TAINT=$(cat /proc/sys/kernel/tainted)
-
-@@ -46,7 +44,7 @@ do
-
- check_tainted
-
-- chmod 755 ../tmp
-+ chmod 755 $TRINITY_TMP
-
- done
-
-diff --git a/scripts/test-all-syscalls-parallel.sh b/scripts/test-all-syscalls-parallel.sh
-index c713cce..312fd2a 100755
---- a/scripts/test-all-syscalls-parallel.sh
-+++ b/scripts/test-all-syscalls-parallel.sh
-@@ -1,12 +1,10 @@
- #!/bin/bash
-
- TRINITY_PATH=${TRINITY_PATH:-.}
-+TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-
--if [ ! -d tmp ]; then
-- mkdir tmp
--fi
--chmod 755 tmp
--cd tmp
-+chmod 755 $TRINITY_TMP
-+cd $TRINITY_TMP
-
- while [ 1 ];
- do
-diff --git a/scripts/test-all-syscalls-sequentially.sh b/scripts/test-all-syscalls-sequentially.sh
-index 6d79db4..2b726fc 100755
---- a/scripts/test-all-syscalls-sequentially.sh
-+++ b/scripts/test-all-syscalls-sequentially.sh
-@@ -4,6 +4,7 @@
- # causing trinity to segfault.
-
- TRINITY_PATH=${TRINITY_PATH:-.}
-+TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-
- check_tainted()
- {
-@@ -13,18 +14,14 @@ check_tainted()
- fi
- }
-
--if [ ! -d tmp ]; then
-- mkdir tmp
--fi
--
- TAINT=$(cat /proc/sys/kernel/tainted)
-
- while [ 1 ]
- do
- for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
- do
-- chmod 755 tmp
-- pushd tmp
-+ chmod 755 $TRINITY_TMP
-+ pushd $TRINITY_TMP
-
- if [ ! -f $TRINITY_PATH/trinity ]; then
- echo lost!
-diff --git a/scripts/test-multi.sh b/scripts/test-multi.sh
-index 33db834..65214c3 100755
---- a/scripts/test-multi.sh
-+++ b/scripts/test-multi.sh
-@@ -1,6 +1,7 @@
- #!/bin/bash
-
- TRINITY_PATH=${TRINITY_PATH:-.}
-+TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-
- check_tainted()
- {
-@@ -10,11 +11,8 @@ check_tainted()
- fi
- }
-
--if [ ! -d tmp ]; then
-- mkdir tmp
--fi
--chmod 755 tmp
--cd tmp
-+chmod 755 $TRINITY_TMP
-+cd $TRINITY_TMP
-
- TAINT=$(cat /proc/sys/kernel/tainted)
-
-@@ -27,7 +25,7 @@ do
-
- for i in `seq 1 $NR_PROCESSES`
- do
-- chmod 755 ../tmp
-+ chmod 755 ../$TRINITY_TMP
- if [ -d tmp.$i ]; then
- chmod 755 tmp.$i
- rm -rf tmp.$i
-@@ -53,7 +51,7 @@ do
- sleep 1
- check_tainted
-
-- chmod 755 ../tmp
-+ chmod 755 ../$TRINITY_TMP
-
- for i in `seq 1 $NR_PROCESSES`
- do
-diff --git a/scripts/test-vm.sh b/scripts/test-vm.sh
-index 6b75e8d..6804c0e 100755
---- a/scripts/test-vm.sh
-+++ b/scripts/test-vm.sh
-@@ -1,12 +1,10 @@
- #!/bin/bash
-
- TRINITY_PATH=${TRINITY_PATH:-.}
-+TRINITY_TMP=$(mktemp -d /tmp/trinity.XXXXXX)
-
--if [ ! -d tmp ]; then
-- mkdir tmp
--fi
--chmod 755 tmp
--cd tmp
-+chmod 755 $TRINITY_TMP
-+cd $TRINITY_TMP
-
- NR_CPUS=`grep ^processor /proc/cpuinfo | /usr/bin/wc -l`
- NR_PROCESSES=$(($NR_CPUS * 2))
---
-1.8.1.2
-
diff --git a/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch b/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch
deleted file mode 100644
index bc5a4831..00000000
--- a/meta-linaro/recipes-extra/trinity/files/0003-tables.c-change-the-output-format-of-L.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 2bddde3a834bd19a6e72761b98ad2e57956af42e Mon Sep 17 00:00:00 2001
-From: Anders Roxell <anders.roxell@linaro.org>
-Date: Thu, 10 Oct 2013 09:46:01 +0200
-Subject: [PATCH 3/4] tables.c: change the output format of -L
-
-So the scripts can works for both biarch and !biarch
-
-Upstream-Status: Backport
-
-Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
----
- scripts/find.sh | 2 +-
- scripts/test-all-syscalls-parallel.sh | 2 +-
- scripts/test-all-syscalls-sequentially.sh | 2 +-
- tables.c | 10 +++++-----
- 4 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/scripts/find.sh b/scripts/find.sh
-index 3f10c58..4c970c1 100755
---- a/scripts/find.sh
-+++ b/scripts/find.sh
-@@ -27,7 +27,7 @@ while [ 1 ];
- do
-
-
--for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for sc in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
- do
- mkdir -p tmp.$i
- pushd tmp.$i
-diff --git a/scripts/test-all-syscalls-parallel.sh b/scripts/test-all-syscalls-parallel.sh
-index 312fd2a..7206364 100755
---- a/scripts/test-all-syscalls-parallel.sh
-+++ b/scripts/test-all-syscalls-parallel.sh
-@@ -8,7 +8,7 @@ cd $TRINITY_TMP
-
- while [ 1 ];
- do
-- for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+ for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
- do
- MALLOC_CHECK_=2 $TRINITY_PATH/trinity -q -c $syscall -D &
- done
-diff --git a/scripts/test-all-syscalls-sequentially.sh b/scripts/test-all-syscalls-sequentially.sh
-index 2b726fc..14fb4c3 100755
---- a/scripts/test-all-syscalls-sequentially.sh
-+++ b/scripts/test-all-syscalls-sequentially.sh
-@@ -18,7 +18,7 @@ TAINT=$(cat /proc/sys/kernel/tainted)
-
- while [ 1 ]
- do
--for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $4 }' | sort -u)
-+for syscall in $($TRINITY_PATH/trinity -L | grep entrypoint | grep -v AVOID | awk '{ print $3 }' | sort -u)
- do
- chmod 755 $TRINITY_TMP
- pushd $TRINITY_TMP
-diff --git a/tables.c b/tables.c
-index d12b541..39c49f9 100644
---- a/tables.c
-+++ b/tables.c
-@@ -411,18 +411,18 @@ void dump_syscall_tables(void)
- unsigned int i;
-
- if (biarch == TRUE) {
-- printf("32-bit syscalls: %d\n", max_nr_32bit_syscalls);
-- printf("64-bit syscalls: %d\n", max_nr_64bit_syscalls);
-+ printf("syscalls: %d [32-bit] \n", max_nr_32bit_syscalls);
-+ printf("syscalls: %d [64-bit] \n", max_nr_64bit_syscalls);
-
- for_each_32bit_syscall(i) {
-- printf("32-bit entrypoint %d %s : ", syscalls_32bit[i].entry->number, syscalls_32bit[i].entry->name);
-+ printf("entrypoint %d %s : [32-bit] ", syscalls_32bit[i].entry->number, syscalls_32bit[i].entry->name);
- show_state(syscalls_32bit[i].entry->flags & ACTIVE);
- if (syscalls_32bit[i].entry->flags & AVOID_SYSCALL)
- printf(" AVOID");
- printf("\n");
- }
- for_each_64bit_syscall(i) {
-- printf("64-bit entrypoint %d %s : ", syscalls_64bit[i].entry->number, syscalls_64bit[i].entry->name);
-+ printf("entrypoint %d %s : [64-bit] ", syscalls_64bit[i].entry->number, syscalls_64bit[i].entry->name);
- show_state(syscalls_64bit[i].entry->flags & ACTIVE);
- if (syscalls_64bit[i].entry->flags & AVOID_SYSCALL)
- printf(" AVOID");
-@@ -431,7 +431,7 @@ void dump_syscall_tables(void)
- } else {
- printf("syscalls: %d\n", max_nr_syscalls);
- for_each_syscall(i) {
-- printf("%d %s : ", syscalls[i].entry->number, syscalls[i].entry->name);
-+ printf("entrypoint %d %s : ", syscalls[i].entry->number, syscalls[i].entry->name);
- show_state(syscalls[i].entry->flags & ACTIVE);
- if (syscalls[i].entry->flags & AVOID_SYSCALL)
- printf(" AVOID");
---
-1.8.1.2
-
diff --git a/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch b/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch
deleted file mode 100644
index 7654ef75..00000000
--- a/meta-linaro/recipes-extra/trinity/files/0004-add-support-for-the-AArch64-architecture.patch
+++ /dev/null
@@ -1,389 +0,0 @@
-From 6a7c9d31a1c882a08d8c5f7e7252ed9858bc4f6a Mon Sep 17 00:00:00 2001
-From: Will Deacon <will.deacon@arm.com>
-Date: Fri, 13 Sep 2013 13:56:31 +0100
-Subject: [PATCH 4/4] add support for the AArch64 architecture
-
-This patch wires up support for the AArch64 architecture, which has been
-supported in the mainline kernel (as arm64) since 3.7.
-
-Upstream-Status: Backport
-
-Signed-off-by: Will Deacon <will.deacon@arm.com>
----
- include/arch-aarch64.h | 13 +++
- include/arch-syscalls.h | 3 +
- include/arch.h | 4 +
- include/syscalls-aarch64.h | 284 +++++++++++++++++++++++++++++++++++++++++++++
- ioctls/kvm.c | 2 +-
- tables.c | 3 +
- 6 files changed, 308 insertions(+), 1 deletion(-)
- create mode 100644 include/arch-aarch64.h
- create mode 100644 include/syscalls-aarch64.h
-
-diff --git a/include/arch-aarch64.h b/include/arch-aarch64.h
-new file mode 100644
-index 0000000..c9ae4ee
---- /dev/null
-+++ b/include/arch-aarch64.h
-@@ -0,0 +1,13 @@
-+#define PAGE_OFFSET 0xffffffc000000000UL
-+#define TASK_SIZE (1UL << 39)
-+#define MODULE_ADDR (PAGE_OFFSET - 0x04000000)
-+#define KERNEL_ADDR (PAGE_OFFSET + 0x80000)
-+
-+/* PAGE_SHIFT is 16 ifdef CONFIG_ARM64_64K_PAGES */
-+#define PAGE_SHIFT 12
-+#define PTE_FILE_MAX_BITS 60
-+
-+#define PTRACE_GETREGS 0
-+#define PTRACE_GETFPREGS 0
-+#define PTRACE_SETREGS 0
-+#define PTRACE_SETFPREGS 0
-diff --git a/include/arch-syscalls.h b/include/arch-syscalls.h
-index 509fd53..8a42aa2 100644
---- a/include/arch-syscalls.h
-+++ b/include/arch-syscalls.h
-@@ -32,5 +32,8 @@
- #ifdef __sh__
- #include "syscalls-sh.h"
- #endif
-+#ifdef __aarch64__
-+#include "syscalls-aarch64.h"
-+#endif
-
- #endif /* _ARCH_SYSCALLS_H */
-diff --git a/include/arch.h b/include/arch.h
-index 9c5da89..4be2fb6 100644
---- a/include/arch.h
-+++ b/include/arch.h
-@@ -37,6 +37,10 @@
- #include "arch-sh.h"
- #endif
-
-+#ifdef __aarch64__
-+#include "arch-aarch64.h"
-+#endif
-+
- #ifndef SYSCALL_OFFSET
- #define SYSCALL_OFFSET 0
- #endif
-diff --git a/include/syscalls-aarch64.h b/include/syscalls-aarch64.h
-new file mode 100644
-index 0000000..760f014
---- /dev/null
-+++ b/include/syscalls-aarch64.h
-@@ -0,0 +1,284 @@
-+/*
-+ * Derived from linux/arch/arm64/include/asm/unistd.h
-+ */
-+
-+#include "sanitise.h"
-+#include "syscall.h"
-+#include "syscalls/syscalls.h"
-+
-+struct syscalltable syscalls_aarch64[] = {
-+/* 0 */ { .entry = &syscall_io_setup },
-+/* 1 */ { .entry = &syscall_io_destroy },
-+/* 2 */ { .entry = &syscall_io_submit },
-+/* 3 */ { .entry = &syscall_io_cancel },
-+/* 4 */ { .entry = &syscall_io_getevents },
-+/* 5 */ { .entry = &syscall_setxattr },
-+/* 6 */ { .entry = &syscall_lsetxattr },
-+/* 7 */ { .entry = &syscall_fsetxattr },
-+/* 8 */ { .entry = &syscall_getxattr },
-+/* 9 */ { .entry = &syscall_lgetxattr },
-+/* 10 */ { .entry = &syscall_fgetxattr },
-+/* 11 */ { .entry = &syscall_listxattr },
-+/* 12 */ { .entry = &syscall_llistxattr },
-+/* 13 */ { .entry = &syscall_flistxattr },
-+/* 14 */ { .entry = &syscall_removexattr },
-+/* 15 */ { .entry = &syscall_lremovexattr },
-+/* 16 */ { .entry = &syscall_fremovexattr },
-+/* 17 */ { .entry = &syscall_getcwd },
-+/* 18 */ { .entry = &syscall_lookup_dcookie },
-+/* 19 */ { .entry = &syscall_eventfd2 },
-+/* 20 */ { .entry = &syscall_epoll_create1 },
-+/* 21 */ { .entry = &syscall_epoll_ctl },
-+/* 22 */ { .entry = &syscall_epoll_pwait },
-+/* 23 */ { .entry = &syscall_dup },
-+/* 24 */ { .entry = &syscall_dup3 },
-+/* 25 */ { .entry = &syscall_fcntl },
-+/* 26 */ { .entry = &syscall_inotify_init1 },
-+/* 27 */ { .entry = &syscall_inotify_add_watch },
-+/* 28 */ { .entry = &syscall_inotify_rm_watch },
-+/* 29 */ { .entry = &syscall_ioctl },
-+/* 30 */ { .entry = &syscall_ioprio_set },
-+/* 31 */ { .entry = &syscall_ioprio_get },
-+/* 32 */ { .entry = &syscall_flock },
-+/* 33 */ { .entry = &syscall_mknodat },
-+/* 34 */ { .entry = &syscall_mkdirat },
-+/* 35 */ { .entry = &syscall_unlinkat },
-+/* 36 */ { .entry = &syscall_symlinkat },
-+/* 37 */ { .entry = &syscall_linkat },
-+/* 38 */ { .entry = &syscall_renameat },
-+/* 39 */ { .entry = &syscall_umount },
-+/* 40 */ { .entry = &syscall_mount },
-+/* 41 */ { .entry = &syscall_pivot_root },
-+/* 42 */ { .entry = &syscall_ni_syscall },
-+/* 43 */ { .entry = &syscall_statfs },
-+/* 44 */ { .entry = &syscall_fstatfs },
-+/* 45 */ { .entry = &syscall_truncate },
-+/* 46 */ { .entry = &syscall_ftruncate },
-+/* 47 */ { .entry = &syscall_fallocate },
-+/* 48 */ { .entry = &syscall_faccessat },
-+/* 49 */ { .entry = &syscall_chdir },
-+/* 50 */ { .entry = &syscall_fchdir },
-+/* 51 */ { .entry = &syscall_chroot },
-+/* 52 */ { .entry = &syscall_fchmod },
-+/* 53 */ { .entry = &syscall_fchmodat },
-+/* 54 */ { .entry = &syscall_fchownat },
-+/* 55 */ { .entry = &syscall_fchown },
-+/* 56 */ { .entry = &syscall_openat },
-+/* 57 */ { .entry = &syscall_close },
-+/* 58 */ { .entry = &syscall_vhangup },
-+/* 59 */ { .entry = &syscall_pipe2 },
-+/* 60 */ { .entry = &syscall_quotactl },
-+/* 61 */ { .entry = &syscall_getdents64 },
-+/* 62 */ { .entry = &syscall_lseek },
-+/* 63 */ { .entry = &syscall_read },
-+/* 64 */ { .entry = &syscall_write },
-+/* 65 */ { .entry = &syscall_readv },
-+/* 66 */ { .entry = &syscall_writev },
-+/* 67 */ { .entry = &syscall_pread64 },
-+/* 68 */ { .entry = &syscall_pwrite64 },
-+/* 69 */ { .entry = &syscall_preadv },
-+/* 70 */ { .entry = &syscall_pwritev },
-+/* 71 */ { .entry = &syscall_sendfile64 },
-+/* 72 */ { .entry = &syscall_pselect6 },
-+/* 73 */ { .entry = &syscall_ppoll },
-+/* 74 */ { .entry = &syscall_signalfd4 },
-+/* 75 */ { .entry = &syscall_vmsplice },
-+/* 76 */ { .entry = &syscall_splice },
-+/* 77 */ { .entry = &syscall_tee },
-+/* 78 */ { .entry = &syscall_readlinkat },
-+/* 79 */ { .entry = &syscall_newfstatat },
-+/* 80 */ { .entry = &syscall_newfstat },
-+/* 81 */ { .entry = &syscall_sync },
-+/* 82 */ { .entry = &syscall_fsync },
-+/* 83 */ { .entry = &syscall_fdatasync },
-+/* 84 */ { .entry = &syscall_sync_file_range },
-+/* 85 */ { .entry = &syscall_timerfd_create },
-+/* 86 */ { .entry = &syscall_timerfd_settime },
-+/* 87 */ { .entry = &syscall_timerfd_gettime },
-+/* 88 */ { .entry = &syscall_utimensat },
-+/* 89 */ { .entry = &syscall_acct },
-+/* 90 */ { .entry = &syscall_capget },
-+/* 91 */ { .entry = &syscall_capset },
-+/* 92 */ { .entry = &syscall_personality },
-+/* 93 */ { .entry = &syscall_exit },
-+/* 94 */ { .entry = &syscall_exit_group },
-+/* 95 */ { .entry = &syscall_waitid },
-+/* 96 */ { .entry = &syscall_set_tid_address },
-+/* 97 */ { .entry = &syscall_unshare },
-+/* 98 */ { .entry = &syscall_futex },
-+/* 99 */ { .entry = &syscall_set_robust_list },
-+/* 100 */ { .entry = &syscall_get_robust_list },
-+/* 101 */ { .entry = &syscall_nanosleep },
-+/* 102 */ { .entry = &syscall_getitimer },
-+/* 103 */ { .entry = &syscall_setitimer },
-+/* 104 */ { .entry = &syscall_kexec_load },
-+/* 105 */ { .entry = &syscall_init_module },
-+/* 106 */ { .entry = &syscall_delete_module },
-+/* 107 */ { .entry = &syscall_timer_create },
-+/* 108 */ { .entry = &syscall_timer_gettime },
-+/* 109 */ { .entry = &syscall_timer_getoverrun },
-+/* 110 */ { .entry = &syscall_timer_settime },
-+/* 111 */ { .entry = &syscall_timer_delete },
-+/* 112 */ { .entry = &syscall_clock_settime },
-+/* 113 */ { .entry = &syscall_clock_gettime },
-+/* 114 */ { .entry = &syscall_clock_getres },
-+/* 115 */ { .entry = &syscall_clock_nanosleep },
-+/* 116 */ { .entry = &syscall_syslog },
-+/* 117 */ { .entry = &syscall_ptrace },
-+/* 118 */ { .entry = &syscall_sched_setparam },
-+/* 119 */ { .entry = &syscall_sched_setscheduler },
-+/* 120 */ { .entry = &syscall_sched_getscheduler },
-+/* 121 */ { .entry = &syscall_sched_getparam },
-+/* 122 */ { .entry = &syscall_sched_setaffinity },
-+/* 123 */ { .entry = &syscall_sched_getaffinity },
-+/* 124 */ { .entry = &syscall_sched_yield },
-+/* 125 */ { .entry = &syscall_sched_get_priority_max },
-+/* 126 */ { .entry = &syscall_sched_get_priority_min },
-+/* 127 */ { .entry = &syscall_sched_rr_get_interval },
-+/* 128 */ { .entry = &syscall_restart_syscall },
-+/* 129 */ { .entry = &syscall_kill },
-+/* 130 */ { .entry = &syscall_tkill },
-+/* 131 */ { .entry = &syscall_tgkill },
-+/* 132 */ { .entry = &syscall_sigaltstack },
-+/* 133 */ { .entry = &syscall_rt_sigsuspend },
-+/* 134 */ { .entry = &syscall_rt_sigaction },
-+/* 135 */ { .entry = &syscall_rt_sigprocmask },
-+/* 136 */ { .entry = &syscall_rt_sigpending },
-+/* 137 */ { .entry = &syscall_rt_sigtimedwait },
-+/* 138 */ { .entry = &syscall_rt_sigqueueinfo },
-+/* 139 */ { .entry = &syscall_rt_sigreturn },
-+/* 140 */ { .entry = &syscall_setpriority },
-+/* 141 */ { .entry = &syscall_getpriority },
-+/* 142 */ { .entry = &syscall_reboot },
-+/* 143 */ { .entry = &syscall_setregid },
-+/* 144 */ { .entry = &syscall_setgid },
-+/* 145 */ { .entry = &syscall_setreuid },
-+/* 146 */ { .entry = &syscall_setuid },
-+/* 147 */ { .entry = &syscall_setresuid },
-+/* 148 */ { .entry = &syscall_getresuid },
-+/* 149 */ { .entry = &syscall_setresgid },
-+/* 150 */ { .entry = &syscall_getresgid },
-+/* 151 */ { .entry = &syscall_setfsuid },
-+/* 152 */ { .entry = &syscall_setfsgid },
-+/* 153 */ { .entry = &syscall_times },
-+/* 154 */ { .entry = &syscall_setpgid },
-+/* 155 */ { .entry = &syscall_getpgid },
-+/* 156 */ { .entry = &syscall_getsid },
-+/* 157 */ { .entry = &syscall_setsid },
-+/* 158 */ { .entry = &syscall_getgroups },
-+/* 159 */ { .entry = &syscall_setgroups },
-+/* 160 */ { .entry = &syscall_newuname },
-+/* 161 */ { .entry = &syscall_sethostname },
-+/* 162 */ { .entry = &syscall_setdomainname },
-+/* 163 */ { .entry = &syscall_getrlimit },
-+/* 164 */ { .entry = &syscall_setrlimit },
-+/* 165 */ { .entry = &syscall_getrusage },
-+/* 166 */ { .entry = &syscall_umask },
-+/* 167 */ { .entry = &syscall_prctl },
-+/* 168 */ { .entry = &syscall_getcpu },
-+/* 169 */ { .entry = &syscall_gettimeofday },
-+/* 170 */ { .entry = &syscall_settimeofday },
-+/* 171 */ { .entry = &syscall_adjtimex },
-+/* 172 */ { .entry = &syscall_getpid },
-+/* 173 */ { .entry = &syscall_getppid },
-+/* 174 */ { .entry = &syscall_getuid },
-+/* 175 */ { .entry = &syscall_geteuid },
-+/* 176 */ { .entry = &syscall_getgid },
-+/* 177 */ { .entry = &syscall_getegid },
-+/* 178 */ { .entry = &syscall_gettid },
-+/* 179 */ { .entry = &syscall_sysinfo },
-+/* 180 */ { .entry = &syscall_mq_open },
-+/* 181 */ { .entry = &syscall_mq_unlink },
-+/* 182 */ { .entry = &syscall_mq_timedsend },
-+/* 183 */ { .entry = &syscall_mq_timedreceive },
-+/* 184 */ { .entry = &syscall_mq_notify },
-+/* 185 */ { .entry = &syscall_mq_getsetattr },
-+/* 186 */ { .entry = &syscall_msgget },
-+/* 187 */ { .entry = &syscall_msgctl },
-+/* 188 */ { .entry = &syscall_msgrcv },
-+/* 189 */ { .entry = &syscall_msgsnd },
-+/* 190 */ { .entry = &syscall_semget },
-+/* 191 */ { .entry = &syscall_semctl },
-+/* 192 */ { .entry = &syscall_semtimedop },
-+/* 193 */ { .entry = &syscall_semop },
-+/* 194 */ { .entry = &syscall_shmget },
-+/* 195 */ { .entry = &syscall_shmctl },
-+/* 196 */ { .entry = &syscall_shmat },
-+/* 197 */ { .entry = &syscall_shmdt },
-+/* 198 */ { .entry = &syscall_socket },
-+/* 199 */ { .entry = &syscall_socketpair },
-+/* 200 */ { .entry = &syscall_bind },
-+/* 201 */ { .entry = &syscall_listen },
-+/* 202 */ { .entry = &syscall_accept },
-+/* 203 */ { .entry = &syscall_connect },
-+/* 204 */ { .entry = &syscall_getsockname },
-+/* 205 */ { .entry = &syscall_getpeername },
-+/* 206 */ { .entry = &syscall_sendto },
-+/* 207 */ { .entry = &syscall_recvfrom },
-+/* 208 */ { .entry = &syscall_setsockopt },
-+/* 209 */ { .entry = &syscall_getsockopt },
-+/* 210 */ { .entry = &syscall_shutdown },
-+/* 211 */ { .entry = &syscall_sendmsg },
-+/* 212 */ { .entry = &syscall_recvmsg },
-+/* 213 */ { .entry = &syscall_readahead },
-+/* 214 */ { .entry = &syscall_brk },
-+/* 215 */ { .entry = &syscall_munmap },
-+/* 216 */ { .entry = &syscall_mremap },
-+/* 217 */ { .entry = &syscall_add_key },
-+/* 218 */ { .entry = &syscall_request_key },
-+/* 219 */ { .entry = &syscall_keyctl },
-+/* 220 */ { .entry = &syscall_clone },
-+/* 221 */ { .entry = &syscall_execve },
-+/* 222 */ { .entry = &syscall_mmap },
-+/* 223 */ { .entry = &syscall_fadvise64_64 },
-+/* 224 */ { .entry = &syscall_swapon },
-+/* 225 */ { .entry = &syscall_swapoff },
-+/* 226 */ { .entry = &syscall_mprotect },
-+/* 227 */ { .entry = &syscall_msync },
-+/* 228 */ { .entry = &syscall_mlock },
-+/* 229 */ { .entry = &syscall_munlock },
-+/* 230 */ { .entry = &syscall_mlockall },
-+/* 231 */ { .entry = &syscall_munlockall },
-+/* 232 */ { .entry = &syscall_mincore },
-+/* 233 */ { .entry = &syscall_madvise },
-+/* 234 */ { .entry = &syscall_remap_file_pages },
-+/* 235 */ { .entry = &syscall_mbind },
-+/* 236 */ { .entry = &syscall_get_mempolicy },
-+/* 237 */ { .entry = &syscall_set_mempolicy },
-+/* 238 */ { .entry = &syscall_migrate_pages },
-+/* 239 */ { .entry = &syscall_move_pages },
-+/* 240 */ { .entry = &syscall_rt_tgsigqueueinfo },
-+/* 241 */ { .entry = &syscall_perf_event_open },
-+/* 242 */ { .entry = &syscall_accept4 },
-+/* 243 */ { .entry = &syscall_recvmmsg },
-+/* 244 */ { .entry = &syscall_ni_syscall },
-+/* 245 */ { .entry = &syscall_ni_syscall },
-+/* 246 */ { .entry = &syscall_ni_syscall },
-+/* 247 */ { .entry = &syscall_ni_syscall },
-+/* 248 */ { .entry = &syscall_ni_syscall },
-+/* 249 */ { .entry = &syscall_ni_syscall },
-+/* 250 */ { .entry = &syscall_ni_syscall },
-+/* 251 */ { .entry = &syscall_ni_syscall },
-+/* 252 */ { .entry = &syscall_ni_syscall },
-+/* 253 */ { .entry = &syscall_ni_syscall },
-+/* 254 */ { .entry = &syscall_ni_syscall },
-+/* 255 */ { .entry = &syscall_ni_syscall },
-+/* 256 */ { .entry = &syscall_ni_syscall },
-+/* 257 */ { .entry = &syscall_ni_syscall },
-+/* 258 */ { .entry = &syscall_ni_syscall },
-+/* 259 */ { .entry = &syscall_ni_syscall },
-+/* 260 */ { .entry = &syscall_wait4 },
-+/* 261 */ { .entry = &syscall_prlimit64 },
-+/* 262 */ { .entry = &syscall_fanotify_init },
-+/* 263 */ { .entry = &syscall_fanotify_mark },
-+/* 264 */ { .entry = &syscall_name_to_handle_at },
-+/* 265 */ { .entry = &syscall_open_by_handle_at },
-+/* 266 */ { .entry = &syscall_clock_adjtime },
-+/* 267 */ { .entry = &syscall_syncfs },
-+/* 268 */ { .entry = &syscall_setns },
-+/* 269 */ { .entry = &syscall_sendmmsg },
-+/* 270 */ { .entry = &syscall_process_vm_readv },
-+/* 271 */ { .entry = &syscall_process_vm_writev },
-+/* 272 */ { .entry = &syscall_kcmp },
-+/* 273 */ { .entry = &syscall_finit_module },
-+};
-diff --git a/ioctls/kvm.c b/ioctls/kvm.c
-index 43170c5..f6d184d 100644
---- a/ioctls/kvm.c
-+++ b/ioctls/kvm.c
-@@ -79,7 +79,7 @@ static const struct ioctl kvm_ioctls[] = {
- IOCTL(KVM_ALLOCATE_RMA),
- IOCTL(KVM_PPC_GET_HTAB_FD),
- #endif
--#if defined(__arm__)
-+#if defined(__arm__) || defined(__aarch64__)
- IOCTL(KVM_ARM_SET_DEVICE_ADDR),
- IOCTL(KVM_ARM_VCPU_INIT),
- #endif
-diff --git a/tables.c b/tables.c
-index d12b541..59969c3 100644
---- a/tables.c
-+++ b/tables.c
-@@ -501,6 +501,9 @@ void select_syscall_tables(void)
- #elif defined(__sh__)
- syscalls = copy_syscall_table(syscalls_sh, ARRAY_SIZE(syscalls_sh));
- max_nr_syscalls = ARRAY_SIZE(syscalls_sh);
-+#elif defined(__aarch64__)
-+ syscalls = copy_syscall_table(syscalls_aarch64, ARRAY_SIZE(syscalls_aarch64));
-+ max_nr_syscalls = ARRAY_SIZE(syscalls_aarch64);
- #else
- #error Unknown architecture.
- #endif
---
-1.8.1.2
-
diff --git a/meta-linaro/recipes-extra/trinity/trinity_1.2.bb b/meta-linaro/recipes-extra/trinity/trinity_1.3.bb
index 7ce189cf..a4f27774 100644
--- a/meta-linaro/recipes-extra/trinity/trinity_1.2.bb
+++ b/meta-linaro/recipes-extra/trinity/trinity_1.3.bb
@@ -6,13 +6,9 @@ LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=96094d47cfbd2cc45eb46ce0fc423c04"
COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
-# v1.2 tag
-SRCREV = "bdd0bdcaef753e8d340fc25fbc72a11be47639b0"
+# v1.3 tag
+SRCREV = "7f333fdbb1933e38a67aa136cbf6a1e5df06c775"
SRC_URI = "git://github.com/kernelslacker/trinity.git;protocol=https \
- file://0001-scripts-TRINITY_PATH-defaults-to.patch \
- file://0002-scripts-change-mkdir-tmp-to-mktemp.patch \
- file://0003-tables.c-change-the-output-format-of-L.patch \
- file://0004-add-support-for-the-AArch64-architecture.patch \
"
S = "${WORKDIR}/git"