aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-09-17 15:43:33 -0700
committerKoen Kooi <koen.kooi@linaro.org>2014-09-17 15:45:18 -0700
commit6f3649de9bb5d0ff45aaa8a4f2e7c7904b6f1a2e (patch)
tree19c124541119ba0e4185dd0a025ab151f0127435 /meta-linaro-toolchain
parent0ee8e3a31dc590b600a955ff5f80e892b94b91bc (diff)
eglibc linaro 2.19: pretend to be named 'glibc'
Having an eglibc-initial recipe will keep throwing errors, so let's pretend to be 'glibc' to get rid of those errors. Change-Id: Ic05bea8f41a83ac0fa66d58c8cfc8cae30a9b336 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro-toolchain')
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial.inc78
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial_linaro-2.19.bb11
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-ld.inc6
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-options.inc78
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-package.inc4
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc.inc2
l---------meta-linaro-toolchain/recipes-core/eglibc/glibc-linaro-2.191
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/glibc-locale_linaro-2.19.bb (renamed from meta-linaro-toolchain/recipes-core/eglibc/eglibc-locale_linaro-2.19.bb)0
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/glibc-mtrace_linaro-2.19.bb (renamed from meta-linaro-toolchain/recipes-core/eglibc/eglibc-mtrace_linaro-2.19.bb)0
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/glibc-scripts_linaro-2.19.bb (renamed from meta-linaro-toolchain/recipes-core/eglibc/eglibc-scripts_linaro-2.19.bb)0
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/glibc_linaro-2.19.bb (renamed from meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb)0
11 files changed, 46 insertions, 134 deletions
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial.inc b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial.inc
deleted file mode 100644
index 92402f8f..00000000
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial.inc
+++ /dev/null
@@ -1,78 +0,0 @@
-DEPENDS = "linux-libc-headers virtual/${TARGET_PREFIX}gcc-initial libgcc-initial"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-
-PACKAGES = ""
-PACKAGES_DYNAMIC = ""
-
-STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
-STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${TARGET_ARCH}"
-TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TCBOOTSTRAP}"
-
-do_configure () {
- sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
- chmod +x ${S}/configure
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- find ${S} -name "configure" | xargs touch
- ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
- --prefix=/usr \
- --without-cvs --disable-sanity-checks \
- --with-headers=${STAGING_DIR_TARGET}${includedir} \
- --with-kconfig=${STAGING_BINDIR_NATIVE} \
- --enable-hacker-mode --enable-addons
-}
-
-do_compile () {
- :
-}
-
-do_install () {
- oe_runmake cross-compiling=yes install_root=${D} \
- includedir='${includedir}' prefix='${prefix}' \
- install-bootstrap-headers=yes install-headers
-
- oe_runmake csu/subdir_lib
- mkdir -p ${D}${libdir}/
- install -m 644 csu/crt[1in].o ${D}${libdir}
-
- # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
- # so do them by hand. We can tolerate an empty stubs.h for the moment.
- # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
- mkdir -p ${D}${includedir}/gnu/
- touch ${D}${includedir}/gnu/stubs.h
- cp ${S}/include/features.h ${D}${includedir}/features.h
-
- if [ -e ${B}/bits/stdio_lim.h ]; then
- cp ${B}/bits/stdio_lim.h ${D}${includedir}/bits/
- fi
- # add links to linux-libc-headers: final eglibc build need this.
- for t in linux asm asm-generic; do
- ln -s ${STAGING_DIR_TARGET}${includedir}/$t ${D}${includedir}/
- done
-}
-
-do_install_locale() {
- :
-}
-
-do_siteconfig () {
- :
-}
-
-SSTATEPOSTINSTFUNCS += "eglibcinitial_sstate_postinst"
-eglibcinitial_sstate_postinst() {
- if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
- then
- # Recreate the symlinks to ensure they point to the correct location
- for t in linux asm asm-generic; do
- rm -f ${STAGING_DIR_TCBOOTSTRAP}${includedir}/$t
- ln -s ${STAGING_DIR_TARGET}${includedir}/$t ${STAGING_DIR_TCBOOTSTRAP}${includedir}/
- done
- fi
-}
-
-do_populate_sysroot[sstate-outputdirs] = "${STAGING_DIR_TCBOOTSTRAP}/"
-
-# We don't install any scripts so there is nothing to evacuate
-do_evacuate_scripts () {
- :
-}
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial_linaro-2.19.bb
deleted file mode 100644
index de450796..00000000
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-initial_linaro-2.19.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require eglibc_${PV}.bb
-require eglibc-initial.inc
-
-DEPENDS += "kconfig-frontends-native"
-
-# main eglibc recipes muck with TARGET_CPPFLAGS to point into
-# final target sysroot but we
-# are not there when building eglibc-initial
-# so reset it here
-
-TARGET_CPPFLAGS = ""
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-ld.inc b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-ld.inc
index 6261ae34..962d6668 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-ld.inc
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-ld.inc
@@ -5,7 +5,7 @@ def ld_append_if_tune_exists(d, infos, dict):
infos['ldconfig'].add('{"' + libdir + '/' + dict[tune][0] + '",' + dict[tune][1] + ' }')
infos['lddrewrite'].add(libdir+'/'+dict[tune][0])
-def eglibc_dl_info(d):
+def glibc_dl_info(d):
ld_info_all = {
"mips": ["ld.so.1", "FLAG_ELF_LIBC6"],
"mips64-n32": ["ld.so.1", "FLAG_ELF_LIBC6"],
@@ -52,5 +52,5 @@ def eglibc_dl_info(d):
infos['lddrewrite'] = ' '.join(infos['lddrewrite'])
return infos
-EGLIBC_KNOWN_INTERPRETER_NAMES = "${@eglibc_dl_info(d)['ldconfig']}"
-RTLDLIST = "${@eglibc_dl_info(d)['lddrewrite']}"
+EGLIBC_KNOWN_INTERPRETER_NAMES = "${@glibc_dl_info(d)['ldconfig']}"
+RTLDLIST = "${@glibc_dl_info(d)['lddrewrite']}"
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-options.inc b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-options.inc
index 259e7528..ec174d1a 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-options.inc
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-options.inc
@@ -1,4 +1,4 @@
-def eglibc_cfg(feature, tokens, cnf):
+def glibc_cfg(feature, tokens, cnf):
if type(tokens) == type(""):
tokens = [tokens]
if feature:
@@ -11,7 +11,7 @@ def eglibc_cfg(feature, tokens, cnf):
cnf.extend(["OPTION_EGLIBC_NSSWITCH_FIXED_FUNCTIONS=\"${S}/nss/fixed-nsswitch.functions\""])
# Map distro features to eglibc options settings
-def features_to_eglibc_settings(d):
+def features_to_glibc_settings(d):
cnf = ([])
ipv4 = bb.utils.contains('DISTRO_FEATURES', 'ipv4', True, False, d)
@@ -121,42 +121,42 @@ def features_to_eglibc_settings(d):
new_dep = True
libc_posix_clang_wchar = True
- eglibc_cfg(ipv6, 'OPTION_EGLIBC_ADVANCED_INET6', cnf)
- eglibc_cfg(libc_backtrace, 'OPTION_EGLIBC_BACKTRACE', cnf)
- eglibc_cfg(libc_big_macros, 'OPTION_EGLIBC_BIG_MACROS', cnf)
- eglibc_cfg(libc_bsd, 'OPTION_EGLIBC_BSD', cnf)
- eglibc_cfg(libc_cxx_tests, 'OPTION_EGLIBC_CXX_TESTS', cnf)
- eglibc_cfg(libc_catgets, 'OPTION_EGLIBC_CATGETS', cnf)
- eglibc_cfg(libc_charsets, 'OPTION_EGLIBC_CHARSETS', cnf)
- eglibc_cfg(libc_crypt, 'OPTION_EGLIBC_CRYPT', cnf)
- eglibc_cfg(libc_crypt_ufc, 'OPTION_EGLIBC_CRYPT_UFC', cnf)
- eglibc_cfg(libc_db_aliases, 'OPTION_EGLIBC_DB_ALIASES', cnf)
- eglibc_cfg(libc_envz, 'OPTION_EGLIBC_ENVZ', cnf)
- eglibc_cfg(libc_fcvt, 'OPTION_EGLIBC_FCVT', cnf)
- eglibc_cfg(libc_fmtmsg, 'OPTION_EGLIBC_FMTMSG', cnf)
- eglibc_cfg(libc_fstab, 'OPTION_EGLIBC_FSTAB', cnf)
- eglibc_cfg(libc_ftraverse, 'OPTION_EGLIBC_FTRAVERSE', cnf)
- eglibc_cfg(libc_getlogin, 'OPTION_EGLIBC_GETLOGIN', cnf)
- eglibc_cfg(libc_idn, 'OPTION_EGLIBC_IDN', cnf)
- eglibc_cfg(ipv4, 'OPTION_EGLIBC_INET', cnf)
- eglibc_cfg(libc_inet_anl, 'OPTION_EGLIBC_INET_ANL', cnf)
- eglibc_cfg(libc_libm, 'OPTION_EGLIBC_LIBM', cnf)
- eglibc_cfg(libc_locales, 'OPTION_EGLIBC_LOCALES', cnf)
- eglibc_cfg(libc_locale_code, 'OPTION_EGLIBC_LOCALE_CODE', cnf)
- eglibc_cfg(libc_memusage, 'OPTION_EGLIBC_MEMUSAGE', cnf)
- eglibc_cfg(libc_nis, 'OPTION_EGLIBC_NIS', cnf)
- eglibc_cfg(libc_nsswitch, 'OPTION_EGLIBC_NSSWITCH', cnf)
- eglibc_cfg(libc_rcmd, 'OPTION_EGLIBC_RCMD', cnf)
- eglibc_cfg(libc_rtld_debug, 'OPTION_EGLIBC_RTLD_DEBUG', cnf)
- eglibc_cfg(libc_spawn, 'OPTION_EGLIBC_SPAWN', cnf)
- eglibc_cfg(libc_streams, 'OPTION_EGLIBC_STREAMS', cnf)
- eglibc_cfg(libc_sunrpc, 'OPTION_EGLIBC_SUNRPC', cnf)
- eglibc_cfg(libc_utmp, 'OPTION_EGLIBC_UTMP', cnf)
- eglibc_cfg(libc_utmpx, 'OPTION_EGLIBC_UTMPX', cnf)
- eglibc_cfg(libc_wordexp, 'OPTION_EGLIBC_WORDEXP', cnf)
- eglibc_cfg(libc_posix_clang_wchar, 'OPTION_POSIX_C_LANG_WIDE_CHAR', cnf)
- eglibc_cfg(libc_posix_regexp, 'OPTION_POSIX_REGEXP', cnf)
- eglibc_cfg(libc_posix_regexp_glibc, 'OPTION_POSIX_REGEXP_GLIBC', cnf)
- eglibc_cfg(libc_posix_wchar_io, 'OPTION_POSIX_WIDE_CHAR_DEVICE_IO', cnf)
+ glibc_cfg(ipv6, 'OPTION_EGLIBC_ADVANCED_INET6', cnf)
+ glibc_cfg(libc_backtrace, 'OPTION_EGLIBC_BACKTRACE', cnf)
+ glibc_cfg(libc_big_macros, 'OPTION_EGLIBC_BIG_MACROS', cnf)
+ glibc_cfg(libc_bsd, 'OPTION_EGLIBC_BSD', cnf)
+ glibc_cfg(libc_cxx_tests, 'OPTION_EGLIBC_CXX_TESTS', cnf)
+ glibc_cfg(libc_catgets, 'OPTION_EGLIBC_CATGETS', cnf)
+ glibc_cfg(libc_charsets, 'OPTION_EGLIBC_CHARSETS', cnf)
+ glibc_cfg(libc_crypt, 'OPTION_EGLIBC_CRYPT', cnf)
+ glibc_cfg(libc_crypt_ufc, 'OPTION_EGLIBC_CRYPT_UFC', cnf)
+ glibc_cfg(libc_db_aliases, 'OPTION_EGLIBC_DB_ALIASES', cnf)
+ glibc_cfg(libc_envz, 'OPTION_EGLIBC_ENVZ', cnf)
+ glibc_cfg(libc_fcvt, 'OPTION_EGLIBC_FCVT', cnf)
+ glibc_cfg(libc_fmtmsg, 'OPTION_EGLIBC_FMTMSG', cnf)
+ glibc_cfg(libc_fstab, 'OPTION_EGLIBC_FSTAB', cnf)
+ glibc_cfg(libc_ftraverse, 'OPTION_EGLIBC_FTRAVERSE', cnf)
+ glibc_cfg(libc_getlogin, 'OPTION_EGLIBC_GETLOGIN', cnf)
+ glibc_cfg(libc_idn, 'OPTION_EGLIBC_IDN', cnf)
+ glibc_cfg(ipv4, 'OPTION_EGLIBC_INET', cnf)
+ glibc_cfg(libc_inet_anl, 'OPTION_EGLIBC_INET_ANL', cnf)
+ glibc_cfg(libc_libm, 'OPTION_EGLIBC_LIBM', cnf)
+ glibc_cfg(libc_locales, 'OPTION_EGLIBC_LOCALES', cnf)
+ glibc_cfg(libc_locale_code, 'OPTION_EGLIBC_LOCALE_CODE', cnf)
+ glibc_cfg(libc_memusage, 'OPTION_EGLIBC_MEMUSAGE', cnf)
+ glibc_cfg(libc_nis, 'OPTION_EGLIBC_NIS', cnf)
+ glibc_cfg(libc_nsswitch, 'OPTION_EGLIBC_NSSWITCH', cnf)
+ glibc_cfg(libc_rcmd, 'OPTION_EGLIBC_RCMD', cnf)
+ glibc_cfg(libc_rtld_debug, 'OPTION_EGLIBC_RTLD_DEBUG', cnf)
+ glibc_cfg(libc_spawn, 'OPTION_EGLIBC_SPAWN', cnf)
+ glibc_cfg(libc_streams, 'OPTION_EGLIBC_STREAMS', cnf)
+ glibc_cfg(libc_sunrpc, 'OPTION_EGLIBC_SUNRPC', cnf)
+ glibc_cfg(libc_utmp, 'OPTION_EGLIBC_UTMP', cnf)
+ glibc_cfg(libc_utmpx, 'OPTION_EGLIBC_UTMPX', cnf)
+ glibc_cfg(libc_wordexp, 'OPTION_EGLIBC_WORDEXP', cnf)
+ glibc_cfg(libc_posix_clang_wchar, 'OPTION_POSIX_C_LANG_WIDE_CHAR', cnf)
+ glibc_cfg(libc_posix_regexp, 'OPTION_POSIX_REGEXP', cnf)
+ glibc_cfg(libc_posix_regexp_glibc, 'OPTION_POSIX_REGEXP_GLIBC', cnf)
+ glibc_cfg(libc_posix_wchar_io, 'OPTION_POSIX_WIDE_CHAR_DEVICE_IO', cnf)
return "\n".join(cnf)
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-package.inc b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-package.inc
index 2a91fa68..d4a42eb8 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-package.inc
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-package.inc
@@ -141,9 +141,9 @@ do_evacuate_scripts () {
addtask evacuate_scripts after do_install before do_populate_sysroot do_package
-PACKAGE_PREPROCESS_FUNCS += "eglibc_package_preprocess"
+PACKAGE_PREPROCESS_FUNCS += "glibc_package_preprocess"
-eglibc_package_preprocess () {
+glibc_package_preprocess () {
rm -rf ${PKGD}/${includedir}/eglibc-locale-internal-${MULTIMACH_TARGET_SYS}
rm -rf ${PKGD}/${includedir}/eglibc-scripts-internal-${MULTIMACH_TARGET_SYS}
for i in ${bashscripts}; do
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc.inc b/meta-linaro-toolchain/recipes-core/eglibc/eglibc.inc
index af7f6ade..08ae50ac 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc.inc
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc.inc
@@ -75,7 +75,7 @@ PARALLEL_MAKE = ""
# ensure make uses /bin/bash
EXTRA_OEMAKE += "SHELL=/bin/bash"
-OE_FEATURES = "${@features_to_eglibc_settings(d)}"
+OE_FEATURES = "${@features_to_glibc_settings(d)}"
do_configure_prepend() {
sed -e "s#@BASH@#/bin/sh#" -i ${S}/elf/ldd.bash.in
echo '${OE_FEATURES}' > ${B}/option-groups.config
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/glibc-linaro-2.19 b/meta-linaro-toolchain/recipes-core/eglibc/glibc-linaro-2.19
new file mode 120000
index 00000000..2ebd7302
--- /dev/null
+++ b/meta-linaro-toolchain/recipes-core/eglibc/glibc-linaro-2.19
@@ -0,0 +1 @@
+eglibc-linaro-2.19/ \ No newline at end of file
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-locale_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/glibc-locale_linaro-2.19.bb
index ce6c1d23..ce6c1d23 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-locale_linaro-2.19.bb
+++ b/meta-linaro-toolchain/recipes-core/eglibc/glibc-locale_linaro-2.19.bb
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-mtrace_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/glibc-mtrace_linaro-2.19.bb
index 6fa2be9c..6fa2be9c 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-mtrace_linaro-2.19.bb
+++ b/meta-linaro-toolchain/recipes-core/eglibc/glibc-mtrace_linaro-2.19.bb
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-scripts_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/glibc-scripts_linaro-2.19.bb
index 31133621..31133621 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-scripts_linaro-2.19.bb
+++ b/meta-linaro-toolchain/recipes-core/eglibc/glibc-scripts_linaro-2.19.bb
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/glibc_linaro-2.19.bb
index c5616dc8..c5616dc8 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb
+++ b/meta-linaro-toolchain/recipes-core/eglibc/glibc_linaro-2.19.bb