aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain/recipes-devtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2017-06-20 17:06:28 -0400
committerKoen Kooi <koen.kooi@linaro.org>2017-06-21 20:38:04 +0200
commit94f8b6ed59542ec720f2b35d1135f857e4d81baf (patch)
treee3fa5301e66c8d3c5aae2fe5ae17eb7a042bb997 /meta-linaro-toolchain/recipes-devtools
parent9cac590e8861b29616dd42015159e3037e9462eb (diff)
binutils: update binutils-cross specific patch to follow oe-core
When OE-Core updated binutils to version 2.28, many of the patches got updated and renamed: http://cgit.openembedded.org/openembedded-core/commit/?id=e9f839d5fe70a222cc7b8942f401ac86a10e6604 Most of those do not affect binutils recipes in meta-linaro-toolchain, as patches are listed in version-specific .bb and .inc files for 2.25 and 2.27. But binutils-cross.inc is one of the generic common .inc files in OE-Core, that includes a patch that got renamed. Sync up this one patch with OE-Core to avoid these warnings: WARNING: /OE/master/sources/meta-linaro/meta-linaro-toolchain/recipes-devtools/binutils/binutils-crosssdk_linaro-2.25.bb: Unable to get checksum for binutils-crosssdk-x86_64-arago-linux SRC_URI entry 0002-binutils-cross-Do-not-generate-linker-script-directo.patch: file could not be found WARNING: /OE/master/sources/meta-linaro/meta-linaro-toolchain/recipes-devtools/binutils/binutils-cross_linaro-2.25.bb: Unable to get checksum for binutils-cross-arm SRC_URI entry 0002-binutils-cross-Do-not-generate-linker-script-directo.patch: file could not be found Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools')
-rw-r--r--meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/0002-binutils-cross-Do-not-generate-linker-script-directo.patch (renamed from meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/no-tooldirpaths.patch)26
1 files changed, 20 insertions, 6 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/no-tooldirpaths.patch b/meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/0002-binutils-cross-Do-not-generate-linker-script-directo.patch
index 2bfc8d4d..14299fd1 100644
--- a/meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/no-tooldirpaths.patch
+++ b/meta-linaro-toolchain/recipes-devtools/binutils/binutils-linaro-2.25/0002-binutils-cross-Do-not-generate-linker-script-directo.patch
@@ -1,20 +1,31 @@
+From 7c7de107b4b0a507d2aeca3e3a86d01cb4b51360 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 6 Mar 2017 23:37:05 -0800
+Subject: [PATCH 02/15] binutils-cross: Do not generate linker script
+ directories
+
We don't place target libraries within ${exec_prefix}, we'd always place these
within the target sysroot within the standard library directories. Worse, the
append_to_lib_path code prefixes these paths with the sysroot which makes even
less sense.
-These directories therefore don't make sense in our case and mean we have to
-relocate all the linker scripts if they're present. Dropping them
+These directories therefore don't make sense in our case and mean we have to
+relocate all the linker scripts if they're present. Dropping them
gives a reasonable performance improvement/simplification.
Upstream-Status: Inappropriate
RP 2017/01/30
-Index: git/ld/genscripts.sh
-===================================================================
---- git.orig/ld/genscripts.sh
-+++ git/ld/genscripts.sh
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ ld/genscripts.sh | 23 -----------------------
+ 1 file changed, 23 deletions(-)
+
+diff --git a/ld/genscripts.sh b/ld/genscripts.sh
+index a42c4d7a4b..d727b4d07e 100755
+--- a/ld/genscripts.sh
++++ b/ld/genscripts.sh
@@ -189,29 +189,6 @@ append_to_lib_path()
fi
}
@@ -45,3 +56,6 @@ Index: git/ld/genscripts.sh
if [ "x${LIB_PATH}" = "x" ] && [ "x${USE_LIBPATH}" = xyes ] ; then
libs=${NATIVE_LIB_DIRS}
if [ "x${NATIVE}" = "xyes" ] ; then
+--
+2.12.0
+