aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-06-07 14:47:18 -0400
committerKoen Kooi <koen.kooi@linaro.org>2014-06-16 08:47:38 +0200
commitab3610aefa2786e3172e751c0ae5e5f560e37444 (patch)
tree2aeed54e55c994a3c303fa757ab99852dd32925e /meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
parent435c94b2d4d6778d10aaafc2442439e31c85c30e (diff)
external-toolchain: fix issues with ld-linux linker/loader in OE sysroot
* Multiarch symlink being fixed only for aarch64 and old-name softfp versions, add hardfp too. * When runtime libs are copied into OE sysroot, libc.so script gets updated replacing absolute multiarch paths with relative ones to point to actual libc libraries. But AS_NEEDED portion for ld-linux is no longer points to multiarch location, so it doesn't get updated any more. Add extra sed line. Change-Id: I56dc88fb310c1eabaf86db6f15750388551e2bb4 Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb')
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
index 240d5507..06abb7af 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
@@ -45,7 +45,7 @@ PROVIDES += "\
"
PV = "${ELT_VER_MAIN}"
-PR = "r2"
+PR = "r3"
# https://launchpad.net/linaro-toolchain-binaries
SRC_URI = "file://SUPPORTED"
@@ -79,7 +79,7 @@ do_install() {
fi
# fix up the copied symlinks (they are still pointing to the multiarch directory)
- linker_name="${@base_contains("TUNE_FEATURES", "aarch64", "ld-linux-aarch64.so.1", "ld-linux.so.3",d)}"
+ linker_name="${@base_contains("TUNE_FEATURES", "aarch64", "ld-linux-aarch64.so.1", base_contains("TUNE_FEATURES", "callconvention-hard", "ld-linux-armhf.so.3", "ld-linux.so.3",d), d)}"
ln -sf ld-${ELT_VER_LIBC}.so ${D}${base_libdir}/${linker_name}
ln -sf ../../lib/libnsl.so.1 ${D}${libdir}/libnsl.so
ln -sf ../../lib/librt.so.1 ${D}${libdir}/librt.so
@@ -108,10 +108,10 @@ do_install() {
fi
if [ -f ${D}${libdir}/libc.so ];then
- sed -i -e "s# /lib/${ELT_TARGET_SYS}# ../../lib#g" -e "s# /usr/lib/${ELT_TARGET_SYS}# .#g" ${D}${libdir}/libc.so
+ sed -i -e "s# /lib/${ELT_TARGET_SYS}# ../../lib#g" -e "s# /usr/lib/${ELT_TARGET_SYS}# .#g" -e "s# /lib/ld-linux# ../../lib/ld-linux#g" ${D}${libdir}/libc.so
fi
if [ -f ${D}${base_libdir}/libc.so ];then
- sed -i -e "s# /lib/${ELT_TARGET_SYS}# ../../lib#g" -e "s# /usr/lib/${ELT_TARGET_SYS}# .#g" ${D}${base_libdir}/libc.so
+ sed -i -e "s# /lib/${ELT_TARGET_SYS}# ../../lib#g" -e "s# /usr/lib/${ELT_TARGET_SYS}# .#g" -e "s# /lib/ld-linux# ../../lib/ld-linux#g" ${D}${base_libdir}/libc.so
fi
if [ -f ${D}${libdir}/libpthread.so ];then
sed -i -e "s# /lib/${ELT_TARGET_SYS}# ../../lib#g" -e "s# /usr/lib/${ELT_TARGET_SYS}# .#g" ${D}${libdir}/libpthread.so