aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-26 07:59:15 +0000
committerKhem Raj <raj.khem@gmail.com>2015-02-26 07:59:15 +0000
commite4e31890e377a45f43c111cd7f82a57dd5993d29 (patch)
treecd6456bc45c6905c72537defde6f94dae5f7d3ed /meta-linaro-toolchain/recipes-core
parent0dc86c1650ae48522ec21eb11fe2ac12a9c0c468 (diff)
glibc_2.21.bb: Fix condition to skip parsing the recipe for non-glibc libc
The condition should be uclibc 'or' musl then we know its not glibc right now it checks with 'and' operator, that condition will never be true Change-Id: Ia7fd11ac5a64c5c6dd6e632540e33234d519a179 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-linaro-toolchain/recipes-core')
-rw-r--r--meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
index 63f03833..485b4a2c 100644
--- a/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
+++ b/meta-linaro-toolchain/recipes-core/glibc/glibc_linaro-2.20.bb
@@ -104,7 +104,7 @@ FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-${PV}', '${FILE_DIRN
python __anonymous () {
import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))