aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-integration
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-02-18 16:28:20 -0500
committerKoen Kooi <koen.kooi@linaro.org>2015-02-22 16:36:23 +0800
commitd522c9b9d32af7a3c96e025b985ef98f5b5a81b9 (patch)
tree903280031173675250ba7db51f757d5310f6e8e7 /meta-linaro-integration
parent00e3e7722bdc044d4b9e46ed21e1ec646d35dc19 (diff)
linux-yocto-tiny: overlay to fix parse error in meta-initramfs
Change-Id: If3b919defcf4951888d2175fe09834a001cfa470
Diffstat (limited to 'meta-linaro-integration')
-rw-r--r--meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.10.bb22
-rw-r--r--meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.17.bb21
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.10.bb b/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
new file mode 100644
index 00000000..3248c441
--- /dev/null
+++ b/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.10.bb
@@ -0,0 +1,22 @@
+KBRANCH ?= "standard/tiny/base"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.10.65"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "a2f2be49cd60b8d022fa47daae0a8293c3066b78"
+SRCREV_meta ?= "d5456dd830cad14bd844753b751b83744ced3793"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""
diff --git a/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.17.bb b/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
new file mode 100644
index 00000000..853f8d02
--- /dev/null
+++ b/meta-linaro-integration/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
@@ -0,0 +1,21 @@
+KBRANCH ?= "standard/tiny/base"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "3.17.8"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "0409b1fbed221e61212e17b7637fa54f908d83f6"
+SRCREV_meta ?= "f24c2bf9c298595d00a9d8600841f2b0206e1fba"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.17.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""