aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-integration
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2015-02-22 10:53:51 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2015-02-22 09:08:53 +0000
commit4cd465c7feba019d08d271ee36c28dc1092fcf53 (patch)
treedeb32d79f815c56d1d632bea104b870985fc26d2 /meta-linaro-integration
parent429cdb5de2996145fd545b7b9a4c0dd0b103885d (diff)
pm-qa: drop overlayed recipe - merged in meta-oe
http://cgit.openembedded.org/meta-openembedded/commit/?id=b86f1c6290191475964925657222ece3c17fa24a Change-Id: Ie6dcb24e7b290176cf10cd960e7afb1ded7b5d76 Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-linaro-integration')
-rw-r--r--meta-linaro-integration/recipes-overlayed/pm-qa/pm-qa_git.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-linaro-integration/recipes-overlayed/pm-qa/pm-qa_git.bb b/meta-linaro-integration/recipes-overlayed/pm-qa/pm-qa_git.bb
deleted file mode 100644
index dc16aef9..00000000
--- a/meta-linaro-integration/recipes-overlayed/pm-qa/pm-qa_git.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-DESCRIPTION = "Utilities for testing Power Management"
-HOMEPAGE = "https://wiki.linaro.org/WorkingGroups/PowerManagement/Resources/TestSuite/PmQa"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-PV = "0.4.14"
-
-BRANCH ?= "master"
-
-# Corresponds to tag pm-qa-v0.4.14
-SRCREV = "9111d1930f02337394cf16e84ad2a27f33607cbb"
-
-SRC_URI = "git://git.linaro.org/power/pm-qa.git;protocol=git;branch=${BRANCH}"
-
-S = "${WORKDIR}/git"
-
-CFLAGS += "-pthread"
-
-do_compile () {
- # Find all the .c files in this project and build them.
- for x in `find . -name "*.c"`
- do
- util=`echo ${x} | sed s/.c$//`
- oe_runmake ${util}
- done
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -d ${D}${libdir}/${PN}
-
- # Install the compiled binaries that were built in the previous step
- for x in `find . -name "*.c"`
- do
- util=`echo ${x} | sed s/.c$//`
- util_basename=`basename ${util}`
- install -m 0755 ${util} ${D}${bindir}/${util_basename}
- done
-
- # Install the helper scripts in a subdirectory of $libdir
- for script in `find . -name "*.sh" | grep include`
- do
- # Remove hardcoded relative paths
- sed -i -e 's#..\/utils\/##' ${script}
-
- script_basename=`basename ${script}`
- install -m 0755 $script ${D}${libdir}/${PN}/${script_basename}
- done
-
- # Install the shell scripts NOT in the $libdir directory since those
- # will be installed elsewhere
- for script in `find . -name "*.sh" | grep -v include`
- do
- # if the script includes any helper scripts from the $libdir
- # directory then change the source path to the absolute path
- # to reflect the install location of the helper scripts.
- sed -i -e "s#source ../include#source ${libdir}/${PN}#g" ${script}
- # Remove hardcoded relative paths
- sed -i -e 's#..\/utils\/##' ${script}
-
- script_basename=`basename ${script}`
- install -m 0755 $script ${D}${bindir}/${script_basename}
- done
-}