aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-integration
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-08-09 10:28:04 +0200
committerKoen Kooi <koen.kooi@linaro.org>2014-08-09 09:07:57 +0000
commitfa806f829f299395d664f137d5bef4685312cd6a (patch)
treee02bcd0f634a067205cec6be10be3bef549558a4 /meta-linaro-integration
parent7288581206b3b6797b5083fb8a8f06a74d257341 (diff)
nss-myhostname: overlay for dependency fix
Change-Id: I3b750c1b136a71f9d6bba5e45c9823d46bb4578c Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-linaro-integration')
-rw-r--r--meta-linaro-integration/recipes-overlayed/nss-myhostname/nss-myhostname_0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-linaro-integration/recipes-overlayed/nss-myhostname/nss-myhostname_0.3.bb b/meta-linaro-integration/recipes-overlayed/nss-myhostname/nss-myhostname_0.3.bb
new file mode 100644
index 00000000..b9ddeaf6
--- /dev/null
+++ b/meta-linaro-integration/recipes-overlayed/nss-myhostname/nss-myhostname_0.3.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Name Service Switch module for resolving the local hostname"
+DESCRIPTION = "plugin for the GNU Name Service Switch (NSS) functionality of \
+the GNU C Library (glibc) providing host name resolution for the locally \
+configured system hostname as returned by gethostname(2)."
+HOMEPAGE = "http://0pointer.de/lennart/projects/nss-myhostname/"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f"
+SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2"
+
+inherit autotools
+
+# /etc/nsswitch.conf needs to be present
+RDEPENDS_${PN} = "base-files"
+
+pkg_postinst_${PN} () {
+ sed -e '/^hosts:/s/\s*\<myhostname\>//' \
+ -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
+ -i ${D}${sysconfdir}/nsswitch.conf
+}
+
+pkg_prerm_${PN} () {
+ sed -e '/^hosts:/s/\s*\<myhostname\>//' \
+ -e '/^hosts:/s/\s*myhostname//' \
+ -i ${D}${sysconfdir}/nsswitch.conf
+}