aboutsummaryrefslogtreecommitdiff
path: root/meta-bigendian
diff options
context:
space:
mode:
authorVictor Kamensky <victor.kamensky@linaro.org>2013-10-09 09:16:07 -0700
committerFathi Boudra <fathi.boudra@linaro.org>2013-10-12 13:26:33 +0300
commita809652d1cf4d06b14d0be525dd85a7efdd11864 (patch)
treeb9b8675a3fd0e3a9b55f0259f6322cd452c0b65a /meta-bigendian
parent8f380654390001abb2b524ca4638fa9a598c8c91 (diff)
openssl 1.0.1e: add bbappend for aarch64_be support
Change-Id: Ie71781667200040ba512b8c40aaae465ab495d94 Signed-off-by: Victor Kamensky <victor.kamensky@linaro.org> Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Acked-by: Ard Biesheuvel <ard.biesheuvel@linaro.org> Acked-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-bigendian')
-rw-r--r--meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch14
-rw-r--r--meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend3
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch b/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch
new file mode 100644
index 00000000..b8b5ce02
--- /dev/null
+++ b/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch
@@ -0,0 +1,14 @@
+From: Victor Kamensky <victor.kamensky@linaro.org>
+Subject: add Aarch64 big-endian support
+Acked-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
+
+--- a/Configure
++++ b/Configure
+@@ -458,6 +458,7 @@ my %table=(
+ "linux-uclibceabi-arm","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "linux-uclibceabi-armeb","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "linux-aarch64","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O2 -pipe -g -feliminate-unused-debug-types -Wall -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-aarch64_be","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O2 -pipe -g -feliminate-unused-debug-types -Wall -Wa,--noexecstack -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
+ "linux-avr32","$ENV{'CC'}:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).",
+
diff --git a/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend b/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
new file mode 100644
index 00000000..3fec8ca8
--- /dev/null
+++ b/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+SRC_URI += "file://aarch64_be-build.patch"