aboutsummaryrefslogtreecommitdiff
path: root/meta-aarch64
diff options
context:
space:
mode:
authorRiku Voipio <riku.voipio@linaro.org>2013-10-11 11:36:22 +0300
committerLinaro Code Review <review@review.linaro.org>2013-10-14 08:32:25 +0000
commit4ab27c0229a039b93ecda4e07b96806f4336b034 (patch)
tree3cd32090450d93037e95b540831dcd9c45fcc10b /meta-aarch64
parenta8cca20cf5112e92c1090a622c42a59a3749d44f (diff)
ltp: update to 20130904
Instead of using giturl like in Anders's patch use the sourceforge mirror URL. Also remove to the manual unpack rule and just set S variable to source directory. Aarch64 build fixed by removing system calls that not for aarch64, but 32 bit arm. These should not be used on native aarch64 builds. If they need to be tested, it is better done using ltp compiled for 32bit arm. pm tests also needed a minor fix. v3: add configure flags Amended to fix issues mentioned by Koen. Change-Id: I644779a6f4e4360f24c5b1f27bccfe10ff6b1581 Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
Diffstat (limited to 'meta-aarch64')
-rw-r--r--meta-aarch64/recipes-extended/ltp/files/fix-arm64.patch37
-rw-r--r--meta-aarch64/recipes-extended/ltp/files/fix-pm-tests.patch13
-rw-r--r--meta-aarch64/recipes-extended/ltp/ltp_20130904.bb72
3 files changed, 122 insertions, 0 deletions
diff --git a/meta-aarch64/recipes-extended/ltp/files/fix-arm64.patch b/meta-aarch64/recipes-extended/ltp/files/fix-arm64.patch
new file mode 100644
index 00000000..2fa5b024
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/files/fix-arm64.patch
@@ -0,0 +1,37 @@
+Index: ltp-full-20130904/testcases/kernel/include/aarch64.in
+===================================================================
+--- ltp-full-20130904.orig/testcases/kernel/include/aarch64.in 2013-09-04 10:18:22.000000000 +0300
++++ ltp-full-20130904/testcases/kernel/include/aarch64.in 2013-10-11 11:20:47.565921406 +0300
+@@ -253,5 +253,3 @@
+ syncfs 267
+ setns 268
+ sendmmsg 269
+-cacheflush 0x1002
+-set_tls 0x1005
+Index: ltp-full-20130904/testcases/kernel/include/linux_syscall_numbers.h
+===================================================================
+--- ltp-full-20130904.orig/testcases/kernel/include/linux_syscall_numbers.h 2013-09-04 10:18:22.000000000 +0300
++++ ltp-full-20130904/testcases/kernel/include/linux_syscall_numbers.h 2013-10-11 11:22:20.013925880 +0300
+@@ -801,12 +801,6 @@
+ # ifndef __NR_sendmmsg
+ # define __NR_sendmmsg 269
+ # endif
+-# ifndef __NR_cacheflush
+-# define __NR_cacheflush 0x1002
+-# endif
+-# ifndef __NR_set_tls
+-# define __NR_set_tls 0x1005
+-# endif
+ #endif
+
+
+@@ -12754,9 +12748,6 @@
+ # ifndef __NR_settimeofday
+ # define __NR_settimeofday __LTP__NR_INVALID_SYSCALL
+ # endif
+-# ifndef __NR_set_tls
+-# define __NR_set_tls __LTP__NR_INVALID_SYSCALL
+-# endif
+ # ifndef __NR_setuid
+ # define __NR_setuid __LTP__NR_INVALID_SYSCALL
+ # endif
diff --git a/meta-aarch64/recipes-extended/ltp/files/fix-pm-tests.patch b/meta-aarch64/recipes-extended/ltp/files/fix-pm-tests.patch
new file mode 100644
index 00000000..8db727ae
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/files/fix-pm-tests.patch
@@ -0,0 +1,13 @@
+Index: ltp-full-20130904/testcases/kernel/power_management/get_sched_values.c
+===================================================================
+--- ltp-full-20130904.orig/testcases/kernel/power_management/get_sched_values.c 2013-09-04 10:18:22.000000000 +0300
++++ ltp-full-20130904/testcases/kernel/power_management/get_sched_values.c 2013-10-11 14:57:40.890551214 +0300
+@@ -17,6 +17,8 @@
+ #include <stdio.h>
+ #include "test.h"
+
++const char *TCID = "Power_Management";
++
+ int get_supp_sched_mc(void)
+ {
+ if (tst_kvercmp(2, 6, 29) < 0)
diff --git a/meta-aarch64/recipes-extended/ltp/ltp_20130904.bb b/meta-aarch64/recipes-extended/ltp/ltp_20130904.bb
new file mode 100644
index 00000000..4fb8f672
--- /dev/null
+++ b/meta-aarch64/recipes-extended/ltp/ltp_20130904.bb
@@ -0,0 +1,72 @@
+SUMMARY = "Linux Test Project"
+DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
+HOMEPAGE = "http://ltp.sourceforge.net"
+SECTION = "console/utils"
+
+LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+ file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+ file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
+ file://testcases/kernel/fs/ext4-new-features/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
+ file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
+ file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
+ file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
+ file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+ file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
+ file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
+ file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
+ file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ "
+
+DEPENDS = "attr libaio libcap acl openssl"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/ltp/LTP%20Source/ltp-${PV}/ltp-full-${PV}.tar.bz2 \
+ file://fix-arm64.patch \
+ file://fix-pm-tests.patch \
+ "
+
+SRC_URI[md5sum] = "0cf2ccb7199f8318d413c62a085629f0"
+SRC_URI[sha256sum] = "662c3661a4d1bfbf3187d0835f35e613b43eedc35a840e3283e378a19606ee0b"
+
+export prefix = "/opt/ltp"
+export exec_prefix = "/opt/ltp"
+
+inherit autotools
+
+S = "${WORKDIR}/ltp-full-${PV}"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
+
+do_install(){
+ install -d ${D}/opt/ltp/
+ oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
+
+ # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
+ cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
+
+ # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core
+ # We will add expect for enhancement in future
+ find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
+}
+
+FILES_${PN}-dbg += "/opt/ltp/runtest/.debug \
+ /opt/ltp/testcases/bin/.debug \
+ /opt/ltp/testcases/bin/*/bin/.debug \
+ /opt/ltp/testcases/bin/*/test/.debug \
+ /opt/ltp/scenario_groups/.debug \
+ /opt/ltp/testscripts/.debug \
+ /opt/ltp/testscripts/open_posix_testsuite/.debug \
+ "
+
+FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
+
+FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
+
+RDEPENDS_${PN} = "perl e2fsprogs-mke2fs"
+
+# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
+INHIBIT_PACKAGE_STRIP = "1"
+
+