aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-05 01:48:15 -0500
committerKoen Kooi <koen.kooi@linaro.org>2019-02-05 11:40:33 +0100
commit26e18fde0573bee68fca39984d8a84834f299ed9 (patch)
treed67acffe26392e224184656d340dce29ebba3d75
parentafa3a6818f94798b8bec843b3dc5185c6ca2eeb9 (diff)
external-arm-toolchain: package c++ headers
Since c++ headers are part of gcc and not glibc, they are not located in libc/usr/include/, but instead in include/, so copy and install them too. Also, set up a symlink in case any code looks for them in include/ Change-Id: I4fd076349e3d6d812faa3e1cad92ede90f22511f Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-arm-toolchain/external-arm-toolchain.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/external-arm-toolchain/external-arm-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-arm-toolchain/external-arm-toolchain.bb
index 09c5f415..0c0d38d1 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-arm-toolchain/external-arm-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-arm-toolchain/external-arm-toolchain.bb
@@ -71,6 +71,7 @@ do_install() {
install -d ${D}${libexecdir}
install -d ${D}${datadir}
install -d ${D}${includedir}
+ install -d ${D}/include
cp -a -H ${EXTERNAL_TOOLCHAIN}/${EAT_TARGET_SYS}/${EAT_LIBDIR}/* ${D}${base_libdir}
if [ -d ${EXTERNAL_TOOLCHAIN}/${EAT_TARGET_SYS}/libc/${EAT_LIBDIR}/${EAT_TARGET_SYS} ]; then
@@ -97,6 +98,9 @@ do_install() {
rm -r ${D}${includedir}/${EAT_TARGET_SYS}
fi
+ cp -a ${EXTERNAL_TOOLCHAIN}/${EAT_TARGET_SYS}/include/* ${D}${includedir}
+ ln -sf ../usr/include/c++ ${D}/include/c++
+
# fix up the copied symlinks (they are still pointing to the multiarch directory)
linker_name="${@bb.utils.contains("TUNE_FEATURES", "aarch64", "ld-linux-aarch64.so.1", bb.utils.contains("TUNE_FEATURES", "callconvention-hard", "ld-linux-armhf.so.3", "ld-linux.so.3",d), d)}"
ln -sf ld-${EAT_VER_LIBC}.so ${D}${base_libdir}/${linker_name}
@@ -513,6 +517,7 @@ FILES_${PN}-dbg += "${base_libdir}/debug"
FILES_libstdc++ = "${base_libdir}/libstdc++.so.*"
FILES_libstdc++-dev = "\
+ /include/c++ \
${includedir}/c++/ \
${base_libdir}/libstdc++.so \
${base_libdir}/libstdc++.la \