aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2017-10-30 21:15:59 +0000
committerFathi Boudra <fathi.boudra@linaro.org>2017-11-23 09:22:49 +0000
commit7fd59321c6528059316f99b29bcd538cf52eb604 (patch)
treea787d6ece0b30faf204c1d18ae41dd4148dd62f6
parent6b3a2392c96116f688547d87761340f91541227e (diff)
meta-ilp32: grub: allow empty package (thus installation as dependency)
Fix a problem when adding GRUB as a direct dependency on a packagegroup or image nothing provides grub needed by packagegroup-core-boot-1.0-r17.hikey_ilp32 This happens because this recipe of GRUB only deploys a binary into DEPLOYDIR but does not package anything at all. Change-Id: Ieafc7869a9377f240fea4bc772b9bfa54c4c551d Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
-rw-r--r--meta-ilp32/recipes-overlayed/grub/grub_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-ilp32/recipes-overlayed/grub/grub_git.bb b/meta-ilp32/recipes-overlayed/grub/grub_git.bb
index 85a63d6f..cce2d521 100644
--- a/meta-ilp32/recipes-overlayed/grub/grub_git.bb
+++ b/meta-ilp32/recipes-overlayed/grub/grub_git.bb
@@ -25,4 +25,6 @@ do_deploy() {
cp -a ${B}/grubaa64.efi ${DEPLOYDIR}
}
+ALLOW_EMPTY_${PN} = "1"
+
addtask deploy before do_build after do_install