aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2017-09-29 10:47:43 -0500
committerDaniel Díaz <daniel.diaz@linaro.org>2017-10-05 10:02:38 -0500
commit2a0d8ef1aea08de7ae1af26267436cd5b2e5edf0 (patch)
tree0f6f923c006efc735894e507a2e9de1386add855
parentd79d8ff98a5fa24c4ec42e3ac06982fdc570fddf (diff)
meta-ilp32: perl: undefine libm_lib_version for ILP32
Recent versions of GLIBC got rid of _LIB_VERSION, and said versions are the ones on which ILP32 is going to land, so we can safely say that for ILP32 will run on that recent GLIBC. Besides, said condition is only used for BSD and Cygwin, so no harm done. Generally, this shouldn't be needed, but we bypass Configure and predefine config.sh in the recipe, so this just ensures that the config file is correct for ILP32. Change-Id: I11f6f8db584759492aa3a0e24867af0e396e1f72 Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
-rw-r--r--meta-ilp32/recipes-support/perl/perl_5.24.%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-ilp32/recipes-support/perl/perl_5.24.%.bbappend b/meta-ilp32/recipes-support/perl/perl_5.24.%.bbappend
new file mode 100644
index 00000000..51dbc523
--- /dev/null
+++ b/meta-ilp32/recipes-support/perl/perl_5.24.%.bbappend
@@ -0,0 +1,9 @@
+do_configure_append() {
+ # Fixups for ILP32
+ # This is to do away with LIB_VERSION, no longer defined
+ # by math.h in recent versions of GLIBC.
+ if echo "${TARGET_OS}" | grep -q '^linux.*ilp32$'; then
+ sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
+ config.sh-${TARGET_ARCH}-${TARGET_OS}
+ fi
+}