aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVishal Bhoj <vishal.bhoj@linaro.org>2017-09-05 12:07:13 +0100
committerVishal Bhoj <vishal.bhoj@linaro.org>2017-09-06 05:24:00 +0100
commit123add5ee29b1e855602a04b2a37985ff42f5d5f (patch)
tree0f0b6801b47619d51a7a882c4e54b3aa5ddeb089
parent2abdf621691012b97354cfbf6cbac502c0d0ab92 (diff)
meta-ilp32: conf: add hikey-ilp32 machine configuration
Set right kernel to be build for hikey ilp32 Change-Id: I0d2d85de76b57b76b21f72863f2b949b753409db Signed-off-by: Vishal Bhoj <vishal.bhoj@linaro.org>
-rw-r--r--meta-ilp32/conf/machine/hikey-ilp32.conf46
-rw-r--r--meta-linaro/recipes-kernel/linux/linux-hikey-ilp32_4.12.bb2
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-minimal-ltp.bb1
3 files changed, 47 insertions, 2 deletions
diff --git a/meta-ilp32/conf/machine/hikey-ilp32.conf b/meta-ilp32/conf/machine/hikey-ilp32.conf
new file mode 100644
index 00000000..f70811ad
--- /dev/null
+++ b/meta-ilp32/conf/machine/hikey-ilp32.conf
@@ -0,0 +1,46 @@
+#@TYPE: Machine
+#@NAME: Hikey ILP32
+#@DESCRIPTION: ILP32 build for hikey.
+
+require conf/machine/include/arm64/arch-armv8.inc
+
+DEFAULTTUNE = "aarch64_ilp32"
+
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
+
+XSERVER ?= "xserver-xorg \
+ mesa-driver-swrast \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard"
+
+MACHINE_FEATURES = ""
+
+# Don't include kernels in standard images
+#RDEPENDS_kernel-base = ""
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-hikey-ilp32"
+
+KERNEL_IMAGETYPE = "Image"
+KERNEL_DEVICETREE = "hisilicon/hi6220-hikey.dtb"
+
+# We have to disable SERIAL_CONSOLE due to auto-serial-console
+#SERIAL_CONSOLE = "115200 ttyAMA0"
+
+# Force auto-serial-console to be used by all image types
+# Ideally this would be part of core oe or as a bbclassappend,
+# but as we don't have an easy way to append a class, defining
+# it here
+EXTRA_IMAGE_FEATURES += "autoserial"
+FEATURE_PACKAGES_autoserial = "auto-serial-console"
+
+# we do not want to have getty running on tty1 as we run
+# auto-serial-console there
+USE_VT = "0"
+
+IMAGE_FSTYPES_append = " ext4.gz"
+IMAGE_ROOTFS_ALIGNMENT = "4096"
+EXTRA_IMAGECMD_ext4 += " -L rootfs "
+
+IMAGE_INSTALL_append = " kernel-image"
diff --git a/meta-linaro/recipes-kernel/linux/linux-hikey-ilp32_4.12.bb b/meta-linaro/recipes-kernel/linux/linux-hikey-ilp32_4.12.bb
index d731e208..28abf785 100644
--- a/meta-linaro/recipes-kernel/linux/linux-hikey-ilp32_4.12.bb
+++ b/meta-linaro/recipes-kernel/linux/linux-hikey-ilp32_4.12.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/arm64/linux.git;protoco
S = "${WORKDIR}/git"
-COMPATIBLE_MACHINE = "genericarmv8-ilp32"
+COMPATIBLE_MACHINE = "hikey-ilp32|genericarmv8-ilp32"
KERNEL_IMAGETYPE ?= "Image"
# EXTRA_OEMAKE += "V=1 ARCH=arm64 CROSS_COMPILE=aarch64-oe-linux-gnuilp32-"
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-minimal-ltp.bb b/meta-linaro/recipes-linaro/images/linaro-image-minimal-ltp.bb
index 864ea589..81e09fa0 100644
--- a/meta-linaro/recipes-linaro/images/linaro-image-minimal-ltp.bb
+++ b/meta-linaro/recipes-linaro/images/linaro-image-minimal-ltp.bb
@@ -2,6 +2,5 @@ require recipes-core/images/core-image-minimal.bb
require linaro-image-common.inc
IMAGE_INSTALL += "\
- ${@bb.utils.contains("TUNE_FEATURES", "ilp32", "kernel-image", "", d)} \
ltp \
"