aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVishal Bhoj <vishal.bhoj@linaro.org>2017-08-11 07:12:05 +0100
committerFathi Boudra <fathi.boudra@linaro.org>2017-08-11 06:20:06 +0000
commit84707f4b97d2f822ce5217b369a0bf63f0ab2aed (patch)
tree534ed17f60dff43bf0a92d70ee97a421f194b6ec
parent506525890371807f4c78cd1dafafa0b9836cd840 (diff)
nspr: ilp32: add the right fix for nss and nspr
Change-Id: I304751770a78352d1bcd79dbbe0d3d3ae5e51ebb Signed-off-by: Vishal Bhoj <vishal.bhoj@linaro.org>
-rw-r--r--meta-ilp32/recipes-support/nspr/nspr/0001-Add-arm64-ILP32-support-to-nspr-config.patch78
-rw-r--r--meta-ilp32/recipes-support/nspr/nspr_%.bbappend3
-rw-r--r--meta-ilp32/recipes-support/nss/nss_%.bbappend3
3 files changed, 81 insertions, 3 deletions
diff --git a/meta-ilp32/recipes-support/nspr/nspr/0001-Add-arm64-ILP32-support-to-nspr-config.patch b/meta-ilp32/recipes-support/nspr/nspr/0001-Add-arm64-ILP32-support-to-nspr-config.patch
new file mode 100644
index 00000000..92dc6121
--- /dev/null
+++ b/meta-ilp32/recipes-support/nspr/nspr/0001-Add-arm64-ILP32-support-to-nspr-config.patch
@@ -0,0 +1,78 @@
+From c51989361c7a906d607a73b7865f2f0dbdd548e1 Mon Sep 17 00:00:00 2001
+From: Wookey <wookey@debian.org>
+Date: Fri, 11 Aug 2017 07:03:30 +0100
+Subject: [PATCH] Add arm64 ILP32 support to nspr config
+
+Signed-off-by: Vishal Bhoj <vishal.bhoj@linaro.org>
+---
+ pr/include/md/_linux.cfg | 47 +++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 47 insertions(+)
+
+diff --git a/pr/include/md/_linux.cfg b/pr/include/md/_linux.cfg
+index 8cbf0cb..cc08189 100644
+--- a/pr/include/md/_linux.cfg
++++ b/pr/include/md/_linux.cfg
+@@ -659,6 +659,51 @@
+ #else
+ #error "Unknown Aarch64 endianness."
+ #endif
++
++#ifdef __ILP32__
++
++#define PR_BYTES_PER_BYTE 1
++#define PR_BYTES_PER_SHORT 2
++#define PR_BYTES_PER_INT 4
++#define PR_BYTES_PER_INT64 8
++#define PR_BYTES_PER_LONG 4
++#define PR_BYTES_PER_FLOAT 4
++#define PR_BYTES_PER_DOUBLE 8
++#define PR_BYTES_PER_WORD 4
++#define PR_BYTES_PER_DWORD 8
++
++#define PR_BITS_PER_BYTE 8
++#define PR_BITS_PER_SHORT 16
++#define PR_BITS_PER_INT 32
++#define PR_BITS_PER_INT64 64
++#define PR_BITS_PER_LONG 32
++#define PR_BITS_PER_FLOAT 32
++#define PR_BITS_PER_DOUBLE 64
++#define PR_BITS_PER_WORD 32
++
++#define PR_BITS_PER_BYTE_LOG2 3
++#define PR_BITS_PER_SHORT_LOG2 4
++#define PR_BITS_PER_INT_LOG2 5
++#define PR_BITS_PER_INT64_LOG2 6
++#define PR_BITS_PER_LONG_LOG2 5
++#define PR_BITS_PER_FLOAT_LOG2 5
++#define PR_BITS_PER_DOUBLE_LOG2 6
++#define PR_BITS_PER_WORD_LOG2 5
++
++#define PR_ALIGN_OF_SHORT 2
++#define PR_ALIGN_OF_INT 4
++#define PR_ALIGN_OF_LONG 4
++#define PR_ALIGN_OF_INT64 8
++#define PR_ALIGN_OF_FLOAT 4
++#define PR_ALIGN_OF_DOUBLE 8
++#define PR_ALIGN_OF_POINTER 4
++#define PR_ALIGN_OF_WORD 4
++
++#define PR_BYTES_PER_WORD_LOG2 2
++#define PR_BYTES_PER_DWORD_LOG2 3
++
++#else
++
+ #define IS_64
+
+ #define PR_BYTES_PER_BYTE 1
+@@ -701,6 +746,8 @@
+ #define PR_BYTES_PER_WORD_LOG2 3
+ #define PR_BYTES_PER_DWORD_LOG2 3
+
++#endif
++
+ #elif defined(__hppa__)
+
+ #undef IS_LITTLE_ENDIAN
+--
+2.13.0
+
diff --git a/meta-ilp32/recipes-support/nspr/nspr_%.bbappend b/meta-ilp32/recipes-support/nspr/nspr_%.bbappend
new file mode 100644
index 00000000..c699fec7
--- /dev/null
+++ b/meta-ilp32/recipes-support/nspr/nspr_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-Add-arm64-ILP32-support-to-nspr-config.patch"
diff --git a/meta-ilp32/recipes-support/nss/nss_%.bbappend b/meta-ilp32/recipes-support/nss/nss_%.bbappend
deleted file mode 100644
index 7267b882..00000000
--- a/meta-ilp32/recipes-support/nss/nss_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-do_compile_prepend() {
-export NSS_ENABLE_WERROR=0
-}