aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-10-12 02:12:48 +0000
committerFathi Boudra <fathi.boudra@linaro.org>2017-10-12 07:33:35 +0000
commit75ff66e78a0735f6cd4951a9d8ad447037ca25a2 (patch)
tree2d747efb2f15731929a34b995d30e97f96f55483
parent034d68096d620fc45fe4ccfe191b2ec21fa72966 (diff)
downloadmeta-linaro-75ff66e78a0735f6cd4951a9d8ad447037ca25a2.tar.gz
python-wand: add SRCREV, fix QA issue and add comment about imagemagick version
* use SRCREV instead of tag name, so that bitbake doesn't translate tag to SRCREV every time it's parsing this recipe * fix QA issue: ERROR: QA Issue: python-wand: Files/directories were installed but not shipped in any package: /usr/share /usr/share/README.rst * add comment about imagemagick version needed to use python-wand-native otherwise it will use imagemagick from host Change-Id: Ie0fd3549d31e48a0f5d3a5083f4fc90854d5d25c Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit e487ca4b1590c1104b7a3b20f7bf343a2861b0fc)
-rw-r--r--meta-optee/recipes-devtools/python/python-wand_0.4.4.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/meta-optee/recipes-devtools/python/python-wand_0.4.4.bb b/meta-optee/recipes-devtools/python/python-wand_0.4.4.bb
index 1043987a..9679b9c9 100644
--- a/meta-optee/recipes-devtools/python/python-wand_0.4.4.bb
+++ b/meta-optee/recipes-devtools/python/python-wand_0.4.4.bb
@@ -6,11 +6,33 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=170eafd687d4a2b950819cd5e067e6d5"
SRCNAME = "wand"
-SRC_URI = "git://github.com/dahlia/wand.git;tag=${PV}"
+SRCREV = "c731c620c3c96c409a194dafab396ffbb97d6702"
+SRC_URI = "git://github.com/dahlia/wand.git"
S = "${WORKDIR}/git"
inherit setuptools
+# Requires imagemagick-6 while meta-oe morty and newer provides imagemagick-7 which isn't compatible with wand
+#
+# You can import imagemagick-5 from older meta-oe, before this upgrade:
+# commit ec660639ecea3fcb6e554b6f1bafc504e8f2fc78
+# Author: Randy MacLeod <randy.macleod@windriver.com>
+# Date: Mon Aug 8 17:41:34 2016 -0400
+# imagemagick: upgrade from 6.9.2 to 7.0.2
+# and add this commit on top of that:
+# commit dfcb67af35936a351789044039a55e3fad299c1a
+# Author: Andreas Müller <schnitzeltony@googlemail.com>
+# Date: Sun Sep 18 02:47:26 2016 +0200
+# imagemagick: depend on fftw not virtual/fftw
+#
+# We need this old version becase python-wand-native used here
+# depends on older imagemagick-native as discussed here:
+# https://stackoverflow.com/questions/37011291/python-wand-image-is-not-recognized
+# there still isn't newer python-wand supporting 7.* version:
+# https://github.com/dahlia/wand/blob/4fe2c6ba9cb0d4105361cea6e9e9e83116080473/wand/api.py#L58
+
DEPENDS += " imagemagick-native"
BBCLASSEXTEND = "native"
+
+FILES_${PN} += "${datadir}"