aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-08-06 10:51:24 +0200
committerKoen Kooi <koen.kooi@linaro.org>2014-08-06 10:52:43 +0200
commit092d9b7c45e08d8363d5f98a19af119966132cf3 (patch)
tree8b8c72795719418d02d5163ce74ea911cb303a3f
parenta9717cc19bb6fa9d95385ebd5fea2b3b0826cad9 (diff)
gator: use aarch64 makefile for everything
The regular makefile injects '-mthumb-interwork' in an attempt to be smart. The aarch64 makefile doesn't try to do anything, so use that for everything. Change-Id: I27da91c9a6546641d90e5155d3dfaea0872d8b2f Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index cf77d2df..2e3748a8 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -18,6 +18,8 @@ EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"'
'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
do_compile() {
+ # The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.
+ cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
oe_runmake -C daemon
}