aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-02-24 18:21:22 +0100
committerKen Werner <ken.werner@linaro.org>2012-03-07 14:23:06 +0100
commit0467c7c1cd34ed9d58630f988c281ab819e2401b (patch)
tree7b7ebc333840a41fccee4591abaec7eb641c4afc
parentd8a889c9b9db14ce30e43534bfa197e5bd7d041e (diff)
Initial support for the Linaro GCC 4.6 based toolchain
Allows to build a cross toolchain based on Linaro GCC 4.6 (see: https://launchpad.net/gcc-linaro/4.6). You may set GCCVERSION to "linaro-4.6" in order to build OE-core using the Linaro toolchain. Signed-off-by: Ken Werner <ken.werner@linaro.org>
-rw-r--r--recipes-devtools/gcc/gcc-cross-initial_linaro-4.6.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross-intermediate_linaro-4.6.bb2
-rw-r--r--recipes-devtools/gcc/gcc-cross_linaro-4.6.bb8
-rw-r--r--recipes-devtools/gcc/gcc-linaro-4.6.inc58
-rw-r--r--recipes-devtools/gcc/gcc-runtime_linaro-4.6.bb8
-rw-r--r--recipes-devtools/gcc/gcc_linaro-4.6.bb6
6 files changed, 84 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-cross-initial_linaro-4.6.bb b/recipes-devtools/gcc/gcc-cross-initial_linaro-4.6.bb
new file mode 100644
index 00000000..b082a6eb
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-cross-initial_linaro-4.6.bb
@@ -0,0 +1,2 @@
+require gcc-cross_${PV}.bb
+require recipes-devtools/gcc/gcc-cross-initial.inc
diff --git a/recipes-devtools/gcc/gcc-cross-intermediate_linaro-4.6.bb b/recipes-devtools/gcc/gcc-cross-intermediate_linaro-4.6.bb
new file mode 100644
index 00000000..8b71c5dc
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-cross-intermediate_linaro-4.6.bb
@@ -0,0 +1,2 @@
+require gcc-cross_${PV}.bb
+require recipes-devtools/gcc/gcc-cross-intermediate.inc
diff --git a/recipes-devtools/gcc/gcc-cross_linaro-4.6.bb b/recipes-devtools/gcc/gcc-cross_linaro-4.6.bb
new file mode 100644
index 00000000..f6021145
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-cross_linaro-4.6.bb
@@ -0,0 +1,8 @@
+require gcc-${PV}.inc
+require recipes-devtools/gcc/gcc-cross4.inc
+
+EXTRA_OECONF += "--disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+ --with-system-zlib "
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
diff --git a/recipes-devtools/gcc/gcc-linaro-4.6.inc b/recipes-devtools/gcc/gcc-linaro-4.6.inc
new file mode 100644
index 00000000..39a51154
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-linaro-4.6.inc
@@ -0,0 +1,58 @@
+require recipes-devtools/gcc/gcc-common.inc
+
+PR = "r0"
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/gcc-linaro-4.6-2012.02' ], d)}"
+DEPENDS =+ "mpfr gmp libmpc"
+NATIVEDEPS = "mpfr-native gmp-native libmpc-native zlib-native"
+
+LICENSE="GPL-3.0-with-GCC-exception & GPLv3"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
+ file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
+ file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8"
+
+BINV = "4.6.3"
+SRC_URI = "http://launchpad.net/gcc-linaro/4.6/4.6-2012.02/+download/gcc-linaro-4.6-2012.02.tar.bz2"
+
+SRC_URI[md5sum] = "2b7887846f8e5ac1ca58fe4dfaabf5a6"
+SRC_URI[sha256sum] = "cddc96360c46366a98de38c806e0e4eced61dfee5e544e587de636e913b74fe3"
+
+S = "${TMPDIR}/work-shared/gcc-${PV}-${PR}/gcc-${PV}-2012.02"
+B = "${WORKDIR}/gcc-${PV}-2012.02/build.${HOST_SYS}.${TARGET_SYS}"
+
+# Language Overrides
+FORTRAN = ""
+JAVA = ""
+
+EXTRA_OECONF_BASE = " --enable-lto \
+ --enable-libssp \
+ --disable-bootstrap \
+ --disable-libgomp \
+ --disable-libmudflap \
+ --with-system-zlib \
+ --with-linker-hash-style=${LINKER_HASH_STYLE} \
+ --enable-cheaders=c_global "
+
+EXTRA_OECONF_INITIAL = "--disable-libmudflap \
+ --disable-libgomp \
+ --disable-libssp \
+ --disable-libquadmath \
+ --with-system-zlib \
+ --disable-lto \
+ --disable-plugin \
+ --enable-decimal-float=no"
+
+EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap \
+ --disable-libgomp \
+ --disable-libquadmath \
+ --with-system-zlib \
+ --disable-lto \
+ --disable-plugin \
+ --disable-libssp"
+
+EXTRA_OECONF_append_linux-uclibc = " --disable-decimal-float "
+EXTRA_OECONF_append_linux-uclibceabi = " --disable-decimal-float "
+EXTRA_OECONF_append_linux-uclibcspe = " --disable-decimal-float "
diff --git a/recipes-devtools/gcc/gcc-runtime_linaro-4.6.bb b/recipes-devtools/gcc/gcc-runtime_linaro-4.6.bb
new file mode 100644
index 00000000..ba8afc3a
--- /dev/null
+++ b/recipes-devtools/gcc/gcc-runtime_linaro-4.6.bb
@@ -0,0 +1,8 @@
+require gcc-${PV}.inc
+require recipes-devtools/gcc/gcc-configure-runtime.inc
+require recipes-devtools/gcc/gcc-package-runtime.inc
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions"
+EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
diff --git a/recipes-devtools/gcc/gcc_linaro-4.6.bb b/recipes-devtools/gcc/gcc_linaro-4.6.bb
new file mode 100644
index 00000000..676735ae
--- /dev/null
+++ b/recipes-devtools/gcc/gcc_linaro-4.6.bb
@@ -0,0 +1,6 @@
+require gcc-${PV}.inc
+require recipes-devtools/gcc/gcc-configure-target.inc
+require recipes-devtools/gcc/gcc-package-target.inc
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+