aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-03-13 10:20:58 +0100
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-03-13 10:43:27 +0100
commit29aa0a0ab9398df69b9791a19950a1fa4378d405 (patch)
tree330c3b62ef2e781c0ee98d3e8fcac7975b366cc3
parent20c605d00272741bc1c8874329385251391ef683 (diff)
lava-test-runner: add for LAVA tests
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
-rw-r--r--recipes-lava/lava-test-runner/lava-test-runner.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-lava/lava-test-runner/lava-test-runner.bb b/recipes-lava/lava-test-runner/lava-test-runner.bb
new file mode 100644
index 00000000..7427f5be
--- /dev/null
+++ b/recipes-lava/lava-test-runner/lava-test-runner.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "LAVA test runner"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "bzr://code.launchpad.net/+branch/lava-dispatcher"
+SRCREV = "${AUTOREV}"
+#PV = "0.${SRCPV}"
+
+RDEPENDS_${PN} = "bash"
+
+S = "${WORKDIR}/lava-dispatcher"
+
+do_install() {
+ install -d ${D}/lava/bin ${D}/lava/results
+ install -m 0755 lava_test_shell/lava-test-runner-ubuntu ${D}/lava/bin/lava-test-runner
+ install -m 0755 lava_test_shell/lava-test-shell ${D}/lava/bin
+}
+
+FILES_${PN} += "/lava"
+
+inherit allarch