aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-03 20:05:14 -0800
committerKoen Kooi <koen.kooi@linaro.org>2015-02-04 09:38:11 +0100
commit06008235ca752fea678953e85adaa29a491d246b (patch)
tree241faa816d67122810a92f0aee4235db24f6cb49
parentbc63e777ad2748b8bfa7fa70ffd74700fa21a567 (diff)
eglibc-linaro: Sync patches from OE-Core
These patches are needed for meta-linaro to use gold and sstate Change-Id: I9cb885019b72638b8f63afac34a7c5b374a95e43 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/CVE-2014-5119.patch240
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/grok_gold.patch34
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/ppce6500-32b_slow_ieee754_sqrt.patch47
-rw-r--r--meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb3
4 files changed, 324 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/CVE-2014-5119.patch b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/CVE-2014-5119.patch
new file mode 100644
index 00000000..51c70374
--- /dev/null
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/CVE-2014-5119.patch
@@ -0,0 +1,240 @@
+CVE-2014-5119
+
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Upstream commit:
+
+https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=a1a6a401ab0a3c9f15fb7eaebbdcee24192254e8
+
+
+From a1a6a401ab0a3c9f15fb7eaebbdcee24192254e8 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 26 Aug 2014 19:38:59 +0200
+Subject: [PATCH] __gconv_translit_find: Disable function [BZ #17187]
+
+This functionality has never worked correctly, and the implementation
+contained a security vulnerability (CVE-2014-5119).
+---
+ ChangeLog | 7 ++
+ NEWS | 9 ++-
+ iconv/gconv_trans.c | 177 +-------------------------------------------------
+ 3 files changed, 19 insertions(+), 174 deletions(-)
+
+Index: libc/NEWS
+===================================================================
+--- libc.orig/NEWS
++++ libc/NEWS
+@@ -26,7 +26,7 @@ Version 2.19
+ 16271, 16274, 16283, 16289, 16293, 16314, 16316, 16330, 16337, 16338,
+ 16356, 16365, 16366, 16369, 16372, 16375, 16379, 16384, 16385, 16386,
+ 16387, 16390, 16394, 16398, 16400, 16407, 16408, 16414, 16430, 16431,
+- 16453, 16474, 16506, 16510, 16529
++ 16453, 16474, 16506, 16510, 16529, 17187
+
+ * Slovenian translations for glibc messages have been contributed by the
+ Translation Project's Slovenian team of translators.
+Index: libc/iconv/gconv_trans.c
+===================================================================
+--- libc.orig/iconv/gconv_trans.c
++++ libc/iconv/gconv_trans.c
+@@ -241,181 +241,12 @@ __gconv_transliterate (struct __gconv_st
+ return __GCONV_ILLEGAL_INPUT;
+ }
+
+-
+-/* Structure to represent results of found (or not) transliteration
+- modules. */
+-struct known_trans
+-{
+- /* This structure must remain the first member. */
+- struct trans_struct info;
+-
+- char *fname;
+- void *handle;
+- int open_count;
+-};
+-
+-
+-/* Tree with results of previous calls to __gconv_translit_find. */
+-static void *search_tree;
+-
+-/* We modify global data. */
+-__libc_lock_define_initialized (static, lock);
+-
+-
+-/* Compare two transliteration entries. */
+-static int
+-trans_compare (const void *p1, const void *p2)
+-{
+- const struct known_trans *s1 = (const struct known_trans *) p1;
+- const struct known_trans *s2 = (const struct known_trans *) p2;
+-
+- return strcmp (s1->info.name, s2->info.name);
+-}
+-
+-
+-/* Open (maybe reopen) the module named in the struct. Get the function
+- and data structure pointers we need. */
+-static int
+-open_translit (struct known_trans *trans)
+-{
+- __gconv_trans_query_fct queryfct;
+-
+- trans->handle = __libc_dlopen (trans->fname);
+- if (trans->handle == NULL)
+- /* Not available. */
+- return 1;
+-
+- /* Find the required symbol. */
+- queryfct = __libc_dlsym (trans->handle, "gconv_trans_context");
+- if (queryfct == NULL)
+- {
+- /* We cannot live with that. */
+- close_and_out:
+- __libc_dlclose (trans->handle);
+- trans->handle = NULL;
+- return 1;
+- }
+-
+- /* Get the context. */
+- if (queryfct (trans->info.name, &trans->info.csnames, &trans->info.ncsnames)
+- != 0)
+- goto close_and_out;
+-
+- /* Of course we also have to have the actual function. */
+- trans->info.trans_fct = __libc_dlsym (trans->handle, "gconv_trans");
+- if (trans->info.trans_fct == NULL)
+- goto close_and_out;
+-
+- /* Now the optional functions. */
+- trans->info.trans_init_fct =
+- __libc_dlsym (trans->handle, "gconv_trans_init");
+- trans->info.trans_context_fct =
+- __libc_dlsym (trans->handle, "gconv_trans_context");
+- trans->info.trans_end_fct =
+- __libc_dlsym (trans->handle, "gconv_trans_end");
+-
+- trans->open_count = 1;
+-
+- return 0;
+-}
+-
+-
+ int
+ internal_function
+ __gconv_translit_find (struct trans_struct *trans)
+ {
+- struct known_trans **found;
+- const struct path_elem *runp;
+- int res = 1;
+-
+- /* We have to have a name. */
+- assert (trans->name != NULL);
+-
+- /* Acquire the lock. */
+- __libc_lock_lock (lock);
+-
+- /* See whether we know this module already. */
+- found = __tfind (trans, &search_tree, trans_compare);
+- if (found != NULL)
+- {
+- /* Is this module available? */
+- if ((*found)->handle != NULL)
+- {
+- /* Maybe we have to reopen the file. */
+- if ((*found)->handle != (void *) -1)
+- /* The object is not unloaded. */
+- res = 0;
+- else if (open_translit (*found) == 0)
+- {
+- /* Copy the data. */
+- *trans = (*found)->info;
+- (*found)->open_count++;
+- res = 0;
+- }
+- }
+- }
+- else
+- {
+- size_t name_len = strlen (trans->name) + 1;
+- int need_so = 0;
+- struct known_trans *newp;
+-
+- /* We have to continue looking for the module. */
+- if (__gconv_path_elem == NULL)
+- __gconv_get_path ();
+-
+- /* See whether we have to append .so. */
+- if (name_len <= 4 || memcmp (&trans->name[name_len - 4], ".so", 3) != 0)
+- need_so = 1;
+-
+- /* Create a new entry. */
+- newp = (struct known_trans *) malloc (sizeof (struct known_trans)
+- + (__gconv_max_path_elem_len
+- + name_len + 3)
+- + name_len);
+- if (newp != NULL)
+- {
+- char *cp;
+-
+- /* Clear the struct. */
+- memset (newp, '\0', sizeof (struct known_trans));
+-
+- /* Store a copy of the module name. */
+- newp->info.name = cp = (char *) (newp + 1);
+- cp = __mempcpy (cp, trans->name, name_len);
+-
+- newp->fname = cp;
+-
+- /* Search in all the directories. */
+- for (runp = __gconv_path_elem; runp->name != NULL; ++runp)
+- {
+- cp = __mempcpy (__stpcpy ((char *) newp->fname, runp->name),
+- trans->name, name_len);
+- if (need_so)
+- memcpy (cp, ".so", sizeof (".so"));
+-
+- if (open_translit (newp) == 0)
+- {
+- /* We found a module. */
+- res = 0;
+- break;
+- }
+- }
+-
+- if (res)
+- newp->fname = NULL;
+-
+- /* In any case we'll add the entry to our search tree. */
+- if (__tsearch (newp, &search_tree, trans_compare) == NULL)
+- {
+- /* Yickes, this should not happen. Unload the object. */
+- res = 1;
+- /* XXX unload here. */
+- }
+- }
+- }
+-
+- __libc_lock_unlock (lock);
+-
+- return res;
++ /* Transliteration module loading has been removed because it never
++ worked as intended and suffered from a security vulnerability.
++ Consequently, this function always fails. */
++ return 1;
+ }
+Index: libc/ChangeLog
+===================================================================
+--- libc.orig/ChangeLog
++++ libc/ChangeLog
+@@ -1,3 +1,10 @@
++2014-08-26 Florian Weimer <fweimer@redhat.com>
++
++ [BZ #17187]
++ * iconv/gconv_trans.c (struct known_trans, search_tree, lock,
++ trans_compare, open_translit, __gconv_translit_find):
++ Remove module loading code.
++
+ 2014-02-06 Carlos O'Donell <carlos@redhat.com>
+
+ [BZ #16529]
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/grok_gold.patch b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/grok_gold.patch
new file mode 100644
index 00000000..d46737af
--- /dev/null
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/grok_gold.patch
@@ -0,0 +1,34 @@
+Make ld --version output matching grok gold's output
+
+adapted from from upstream branch roland/gold-vs-libc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Backport
+
+
+Index: libc/configure
+===================================================================
+--- libc.orig/configure
++++ libc/configure
+@@ -4654,7 +4654,7 @@ else
+ # Found it, now check the version.
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking version of $LD" >&5
+ $as_echo_n "checking version of $LD... " >&6; }
+- ac_prog_version=`$LD --version 2>&1 | sed -n 's/^.*GNU ld.* \([0-9][0-9]*\.[0-9.]*\).*$/\1/p'`
++ ac_prog_version=`$LD --version 2>&1 | sed -n 's/^.*GNU [Bbinutilsd][^.]* \([0-9][0-9]*\.[0-9.]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+ 2.1[0-9][0-9]*|2.[2-9][0-9]*|[3-9].*|[1-9][0-9]*)
+Index: libc/configure.ac
+===================================================================
+--- libc.orig/configure.ac
++++ libc/configure.ac
+@@ -990,7 +990,7 @@ AC_CHECK_PROG_VER(AS, $AS, --version,
+ [GNU assembler.* \([0-9]*\.[0-9.]*\)],
+ [2.1[0-9][0-9]*|2.[2-9][0-9]*|[3-9].*|[1-9][0-9]*], AS=: critic_missing="$critic_missing as")
+ AC_CHECK_PROG_VER(LD, $LD, --version,
+- [GNU ld.* \([0-9][0-9]*\.[0-9.]*\)],
++ [GNU [Bbinutilsd][^.]* \([0-9][0-9]*\.[0-9.]*\)],
+ [2.1[0-9][0-9]*|2.[2-9][0-9]*|[3-9].*|[1-9][0-9]*], LD=: critic_missing="$critic_missing ld")
+
+ # These programs are version sensitive.
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/ppce6500-32b_slow_ieee754_sqrt.patch b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/ppce6500-32b_slow_ieee754_sqrt.patch
new file mode 100644
index 00000000..4c6c1070
--- /dev/null
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc-linaro-2.19/ppce6500-32b_slow_ieee754_sqrt.patch
@@ -0,0 +1,47 @@
+ __ieee754_sqrt{,f} are now inline functions and call out __slow versions
+
+
+Signed-off-by: chunrong guo <B40290@freescale.com>
+Upstream-Status: Pending
+
+diff -rNu libc-orig/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrt.c libc/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrt.c
+--- libc-orig/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrt.c 2014-04-08 04:39:58.487229887 -0500
++++ libc/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrt.c 2014-04-08 04:40:52.643069198 -0500
+@@ -41,10 +41,10 @@
+
+ #ifdef __STDC__
+ double
+-__ieee754_sqrt (double b)
++__slow_ieee754_sqrt (double b)
+ #else
+ double
+-__ieee754_sqrt (b)
++__slow_ieee754_sqrt (b)
+ double b;
+ #endif
+ {
+@@ -83,7 +83,7 @@
+
+ /* Handle small numbers by scaling. */
+ if (__builtin_expect ((u.parts.msw & 0x7ff00000) <= 0x02000000, 0))
+- return __ieee754_sqrt (b * two108) * twom54;
++ return __slow_ieee754_sqrt (b * two108) * twom54;
+
+ #define FMADD(a_, c_, b_) \
+ ({ double __r; \
+diff -rNu libc-orig/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrtf.c libc/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrtf.c
+--- libc-orig/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrtf.c 2014-04-08 04:39:58.487229887 -0500
++++ libc/sysdeps/powerpc/powerpc32/e6500/fpu/e_sqrtf.c 2014-04-08 04:41:26.017067682 -0500
+@@ -39,10 +39,10 @@
+
+ #ifdef __STDC__
+ float
+-__ieee754_sqrtf (float b)
++__slow_ieee754_sqrtf (float b)
+ #else
+ float
+-__ieee754_sqrtf (b)
++__slow_ieee754_sqrtf (b)
+ float b;
+ #endif
+ {
diff --git a/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb b/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb
index b85181bc..8aae1c5a 100644
--- a/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb
+++ b/meta-linaro-toolchain/recipes-core/eglibc/eglibc_linaro-2.19.bb
@@ -28,6 +28,9 @@ SRC_URI = "http://cbuild.validation.linaro.org/snapshots/eglibc-${PV}-${RELEASE}
file://0001-R_ARM_TLS_DTPOFF32.patch \
file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
file://fix-tibetian-locales.patch \
+ file://ppce6500-32b_slow_ieee754_sqrt.patch \
+ file://grok_gold.patch \
+ file://CVE-2014-5119.patch \
"
SRC_URI[md5sum] = "4d9a406039cd33e14349a63773daac61"