aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-03-05 08:37:32 +0100
committerKen Werner <ken.werner@linaro.org>2012-03-07 14:23:06 +0100
commit587915c748541d7dd1adb87345bfdb33a5876bf8 (patch)
treeb11250804d58806f2bdf0a011a1393a731288596
parentf58483c3d029568e4b256669f1e04b2a076b5a91 (diff)
external-linaro-toolchain: update to work with OE-core head again
This change skips the external-linaro-toolchain if ELT_VER_MAIN is not set. These are the corresponding OE-core changes: http://git.openembedded.org/openembedded-core/commit/?id=f2b572072c754048aaafdc4c42b71af87d61d9e7 http://git.openembedded.org/openembedded-core/commit/?id=264d1254e5ac11613af06c0f1c53c736f54e9f54 Signed-off-by: Ken Werner <ken.werner@linaro.org>
-rw-r--r--recipes-devtools/external-linaro-toolchain.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-devtools/external-linaro-toolchain.bb b/recipes-devtools/external-linaro-toolchain.bb
index 5c210481..d68f77fa 100644
--- a/recipes-devtools/external-linaro-toolchain.bb
+++ b/recipes-devtools/external-linaro-toolchain.bb
@@ -29,7 +29,7 @@ PV = "${ELT_VER_MAIN}"
PR = "r0"
# https://launchpad.net/linaro-toolchain-binaries
-# http://launchpad.net/linaro-toolchain-binaries/trunk/2012.01/+download/gcc-linaro-arm-linux-gnueabi-2012.01-20120125_linux.tar.bz2
+# http://launchpad.net/linaro-toolchain-binaries/trunk/2012.02/+download/gcc-linaro-arm-linux-gnueabi-2012.02-20120222_linux.tar.bz2
SRC_URI = "file://SUPPORTED"
do_install() {
@@ -189,3 +189,8 @@ FILES_${PN} += "\
${base_libdir}/libSegFault.so \
${base_libdir}/libpcprofile.so \
"
+ELT_VER_MAIN ??= ""
+
+python () {
+ if not d.getVar("ELT_VER_MAIN"):
+ raise bb.parse.SkipPackage("External Linaro toolchain not configured (ELT_VER_MAIN not set).")