aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-05-14 18:35:20 +0200
committerKen Werner <ken.werner@linaro.org>2012-05-14 18:35:20 +0200
commit79379b7ab05198ad5755321be0cd7785bf65c189 (patch)
treef5318d40af1e214987c6ceac20aa0e354e4f7b64
parent73c717d77069453f41ae252733309e3ab990e238 (diff)
Simplify the linux-yocto_3.2.bbappend
Using 'COMPATIBLE_MACHINE_qemuarmv7'a instead of just setting 'COMPATIBLE_MACHINE' avoids the need of knowing all the other MACHINEs. Using 'FILESEXTRAPATHS_prepend :=' instead of 'FILESEXTRAPATHS =.' ensures immediate expansion. The /${MACHINE} has been removed because bitbake automatically searches the MACHINE subdirectory. Signed-off-by: Ken Werner <ken.werner@linaro.org>
-rw-r--r--recipes-kernel/linux/linux-yocto_3.2.bbappend7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-yocto_3.2.bbappend b/recipes-kernel/linux/linux-yocto_3.2.bbappend
index 1514adfe..16ad9f6f 100644
--- a/recipes-kernel/linux/linux-yocto_3.2.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -1,9 +1,12 @@
KMACHINE_qemuarmv7a = "arm-versatile-926ejs"
KBRANCH_qemuarmv7a = "standard/default/arm-versatile-926ejs"
-COMPATIBLE_MACHINE = "(qemuarm|qemuarmv7a|qemux86|qemuppc|qemumips|qemux86-64)"
+COMPATIBLE_MACHINE_qemuarmv7a = "qemuarmv7a"
-FILESEXTRAPATHS =. "${THISDIR}/${PN}/${MACHINE}:"
+# To find the defconfig in case of "qemuarmv7a" BitBake searches the
+# $MACHINE subdir automatically. Therefore it is sufficient to add the
+# location of this bbappend file to the FILESEXTRAPATHS variable.
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEFCONFIG = ""
DEFCONFIG_qemuarmv7a = "file://defconfig"