aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-03-20 18:12:03 +0100
committerKen Werner <ken.werner@linaro.org>2012-03-20 18:15:10 +0100
commitfc1f7644829a27db0a7469bddc50adbfea896d2f (patch)
treef6f53947ed12740d164806665e9defb0040c26ef
parent479a02a3b3c5bd5530c45c864a8388216781a95b (diff)
Fix install location for some header files
Since OpenEmbedded doesn't support multiarch we de-multiarch the Linaro external binary toolchain during the install step. This change does it for the header files in the same way we do this for the libraries. Signed-off-by: Ken Werner <ken.werner@linaro.org>
-rw-r--r--recipes-devtools/external-linaro-toolchain.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/external-linaro-toolchain.bb b/recipes-devtools/external-linaro-toolchain.bb
index d68f77fa..8c5e3977 100644
--- a/recipes-devtools/external-linaro-toolchain.bb
+++ b/recipes-devtools/external-linaro-toolchain.bb
@@ -47,9 +47,11 @@ do_install() {
cp -a ${EXTERNAL_TOOLCHAIN}/${ELT_TARGET_SYS}/libc/usr/lib/* ${D}${libdir}
cp -a ${EXTERNAL_TOOLCHAIN}/${ELT_TARGET_SYS}/libc/usr/share/* ${D}${datadir}
cp -a ${EXTERNAL_TOOLCHAIN}/${ELT_TARGET_SYS}/libc/usr/include/* ${D}${includedir}
+ cp -a ${EXTERNAL_TOOLCHAIN}/${ELT_TARGET_SYS}/libc/usr/include/${ELT_TARGET_SYS}/* ${D}${includedir}
rm -r ${D}${libdir}/${ELT_TARGET_SYS}
rm -r ${D}${base_libdir}/${ELT_TARGET_SYS}
+ rm -r ${D}${includedir}/${ELT_TARGET_SYS}
# fix up the copied symlinks (they are still pointing to the multiarch directory)
ln -sf ld-2.13.so ${D}${base_libdir}/ld-linux.so.3