aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKen Werner <ken.werner@linaro.org>2012-05-30 13:17:49 +0200
committerKen Werner <ken.werner@linaro.org>2012-05-30 13:17:49 +0200
commit323a98252ca7d66874532f1d6d4e4c8a4fd98e83 (patch)
treee588db4ec1e37a283f461862f2642812a3f0d958
parent561a0deb6b96f10261570d33b1ec8ece991bf166 (diff)
Add xorg.conf for the qemuarmv7a MACHINE
Since OE-Core switched from xserver-kdrive (Xfbdev) to xserver-xorg for QEMU targets we need to provide a xorg.conf for qemuarmv7a. This fixes the GUI for the core-image-sato. Signed-off-by: Ken Werner <ken.werner@linaro.org>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/qemuarmv7a/xorg.conf69
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend2
2 files changed, 71 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/qemuarmv7a/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/qemuarmv7a/xorg.conf
new file mode 100644
index 00000000..629ae214
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/qemuarmv7a/xorg.conf
@@ -0,0 +1,69 @@
+
+Section "Files"
+EndSection
+
+Section "InputDevice"
+ Identifier "Generic Keyboard"
+ Driver "evdev"
+ Option "CoreKeyboard"
+ Option "Device" "/dev/input/by-path/platform-i8042-serio-0-event-kbd"
+ Option "XkbRules" "xorg"
+ Option "XkbModel" "evdev"
+ Option "XkbLayout" "us"
+EndSection
+
+Section "InputDevice"
+ Identifier "Configured Mouse"
+ Driver "mouse"
+ Option "CorePointer"
+ Option "Device" "/dev/input/mice"
+ Option "Protocol" "ImPS/2"
+ Option "ZAxisMapping" "4 5"
+ Option "Emulate3Buttons" "true"
+EndSection
+
+Section "InputDevice"
+ Identifier "Qemu Tablet"
+ Driver "evdev"
+ Option "CorePointer"
+ Option "Device" "/dev/input/touchscreen0"
+ Option "USB" "on"
+EndSection
+
+Section "Device"
+ Identifier "Graphics Controller"
+ Driver "fbdev"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+ # 1024x600 59.85 Hz (CVT) hsync: 37.35 kHz; pclk: 49.00 MHz
+ Modeline "1024x600_60.00" 49.00 1024 1072 1168 1312 600 603 613 624 -hsync +vsync
+ # 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
+ ModeLine "640x480" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
+ # 640x480 @ 72Hz (VESA) hsync: 37.9kHz
+ ModeLine "640x480" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
+ # 640x480 @ 75Hz (VESA) hsync: 37.5kHz
+ ModeLine "640x480" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
+ # 640x480 @ 85Hz (VESA) hsync: 43.3kHz
+ ModeLine "640x480" 36.0 640 696 752 832 480 481 484 509 -hsync -vsync
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Graphics Controller"
+ Monitor "Generic Monitor"
+ SubSection "Display"
+ Modes "640x480"
+ EndSubSection
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+ InputDevice "Generic Keyboard"
+ # InputDevice "Configured Mouse"
+ InputDevice "QEMU Tablet"
+ Option "AllowEmptyInput" "no"
+EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..cf547247
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,2 @@
+# allows bitbake to find the xorg.conf for the qemuarmv7a MACHINE
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"