aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-11-04 08:47:23 +0100
committerKoen Kooi <koen.kooi@linaro.org>2014-11-04 08:48:43 +0100
commit5b74d24a278f343c613ba3caa6f331a58396d1f6 (patch)
treed4c3a465528052de3367afadb4ee7bf9ef0f0d1c
parent4fd96e0094a31a5abb545dd165ee20e561f548b0 (diff)
gator: use CC and CXX from OE
This is needed to get the default sysroot. The workarounds for the sucky upstream makefile are almost larger than said makefile itself. Change-Id: I001b01e3f402fcf27a62ec672ad04be7d54111b0 Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 5e5d6979..1c8431b2 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -21,7 +21,7 @@ EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"'
do_compile() {
# The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.
cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
- oe_runmake -C daemon
+ oe_runmake -C daemon CC='${CC}' CXX='${CXX}'
}
do_install() {