aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2014-08-11 15:48:26 -0500
committerFathi Boudra <fathi.boudra@linaro.org>2014-08-31 13:31:01 +0000
commite4941bd18670137fad5bbd7623e13b59d8883d61 (patch)
tree5bf29902827999ba4bde7038a0abbbb27d9e1334
parent33d98516b82e7cd801a0884e496aac288558f993 (diff)
Remove overlay recipe for libhugetlbfs
The upstream OE recipe for libhugetlbfs now contains all of the patches applied to the meta-linaro overlay recipe, and in addition has added armv7 little-endian support. See the upstream OE recipe at: meta-openembedded/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb A pending patch is being submitted for that recipe which extends support to armv7 le and be. Change-Id: Ib69fc5747f122ef78133b0ba7db7ca1ae8b2c87a Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch34
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch32
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch39
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch29
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch43
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/fix-lib64-can-not-be-shiped-in-64bit-target.patch75
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch99
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch23
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch17
-rw-r--r--meta-linaro-integration/recipes-overlayed/libhugetlbfs/libhugetlbfs_git.bb61
10 files changed, 0 insertions, 452 deletions
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch
deleted file mode 100644
index 215ae728..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-cross-compilation.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Subject: [PATCH] aarch64: fix cross compilation
-
-This patch allow to override CC and use it for aarch64 case like
-the other architectures.
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
-
-Upstream-Status: Submitted
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 91502e1..5aa1e12 100644
---- a/Makefile
-+++ b/Makefile
-@@ -33,7 +33,7 @@ CFLAGS += -Wall -fPIC
- CPPFLAGS += -D__LIBHUGETLBFS__
-
- ARCH = $(shell uname -m | sed -e s/i.86/i386/)
--CC = gcc
-+CC ?= gcc
-
- CUSTOM_LDSCRIPTS = yes
-
-@@ -66,7 +66,7 @@ ELF32 += armelf_linux_eabi
- CUSTOM_LDSCRIPTS = no
- else
- ifneq (,$(findstring aarch64,$(ARCH)))
--CC64 = gcc
-+CC64 = $(CC)
- ELF64 = aarch64elf
- TMPLIB64 = lib64
- CUSTOM_LDSCRIPTS = no
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch
deleted file mode 100644
index da60ba0a..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-aarch64-fix-page-size-not-properly-computed.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Subject: [PATCH] aarch64: fix page size not properly computed
-
-There's 2 issues fixed:
-* typo on MB variable (MB -> $MB)
-* some linker variants are missing (linux and big endian)
- - aarch64elfb
- - aarch64linux
- - aarch64linuxb
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
-
-Upstream-Status: Submitted
----
- ld.hugetlbfs | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ld.hugetlbfs b/ld.hugetlbfs
-index df446dd..6553547 100755
---- a/ld.hugetlbfs
-+++ b/ld.hugetlbfs
-@@ -87,7 +87,7 @@ elf32ppclinux|elf64ppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
- elf64lppc) HPAGE_SIZE=$((16*$MB)) SLICE_SIZE=$((256*$MB)) ;;
- elf_i386|elf_x86_64) HPAGE_SIZE=$((4*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
- elf_s390|elf64_s390) HPAGE_SIZE=$((1*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
--armelf_linux_eabi|aarch64elf) HPAGE_SIZE=$((2*MB)) SLICE_SIZE=$HPAGE_SIZE ;;
-+armelf_linux_eabi|aarch64elf*|aarch64linux*) HPAGE_SIZE=$((2*$MB)) SLICE_SIZE=$HPAGE_SIZE ;;
- esac
-
- if [ "$HTLB_ALIGN" == "slice" ]; then
---
-1.9.2
-
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
deleted file mode 100644
index 0b8d0e4d..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Upstream-Status: Inappropriate [oe-core specific]
-
-libhugetlbfs depends on perl, and perl installs a directory 'perl'
-and make a symlink 'perl5' to it. So just install perl libs in
-libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid
-the following error:
-| CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir
-| -ps . | tar -xf - -C .../tmp/sysroots/t4240qds'
-| returned non-zero exit status 2 with output
-| tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists
-| tar: Exiting with failure status due to previous errors
-
-
-Signed-off-by: Ting Liu <b28495@freescale.com>
-
---- a/Makefileold 2013-10-11 23:07:31.759421318 -0500
-+++ b/Makefile 2013-10-11 23:08:01.935571122 -0500
-@@ -173,17 +173,17 @@
- DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
-
- ifdef CC32
--PMDIR = $(PREFIX)/lib/perl5/TLBC
-+PMDIR = $(PREFIX)/lib/perl/TLBC
- endif
-
- ifdef CC64
- ifeq ($(ARCH),x86_64)
--PMDIR = $(PREFIX)/lib/perl5/TLBC
-+PMDIR = $(PREFIX)/lib/perl/TLBC
- else
- ifeq ($(ARCH),aarch64)
--PMDIR = $(PREFIX)/lib/perl5/TLBC
-+PMDIR = $(PREFIX)/lib/perl/TLBC
- else
--PMDIR = $(PREFIX)/lib64/perl5/TLBC
-+PMDIR = $(PREFIX)/lib64/perl/TLBC
- endif
- endif
- endif
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch
deleted file mode 100644
index 9e2a5e58..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Subject: [PATCH 1/1] Replace lib/lib64 hardcoded values by LIBDIR32/LIBDIR64
- variables
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
-
-Upstream-Status: Submitted
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 91502e1..682c0db 100644
---- a/Makefile
-+++ b/Makefile
-@@ -181,9 +181,9 @@ BINDIR = $(PREFIX)/share/libhugetlbfs
- EXEDIR = $(PREFIX)/bin
- DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
- ifdef CC32
--PMDIR = $(PREFIX)/lib/perl5/TLBC
-+PMDIR = $(LIBDIR32)/perl5/TLBC
- else
--PMDIR = $(PREFIX)/lib64/perl5/TLBC
-+PMDIR = $(LIBDIR64)/perl5/TLBC
- endif
- MANDIR1 = $(PREFIX)/share/man/man1
- MANDIR3 = $(PREFIX)/share/man/man3
---
-1.9.2
-
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
deleted file mode 100644
index 3082d7ef..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From a85fc43243f8bfad12d306a4a0e230fb8b3e828a Mon Sep 17 00:00:00 2001
-From: Ting Liu <b28495@freescale.com>
-Date: Wed, 21 Aug 2013 15:44:57 +0800
-Subject: [PATCH] run_test.py: not use hard coded path ../obj/hugeadm
-
-Hard coded path makes the script impossible to run out of source tree.
-After 'make install', we can use hugeadm utility under DESTDIR.
-
-Upstream-Status: Submitted
-
-Signed-off-by: Ting Liu <b28495@freescale.com>
----
- tests/run_tests.py | 12 +++++++++++-
- 1 files changed, 11 insertions(+), 1 deletions(-)
-
-diff --git a/tests/run_tests.py b/tests/run_tests.py
-index d9a6b35..a9bab8f 100755
---- a/tests/run_tests.py
-+++ b/tests/run_tests.py
-@@ -232,9 +232,19 @@ def get_pagesizes():
- Use libhugetlbfs' hugeadm utility to get a list of page sizes that have
- active mount points and at least one huge page allocated to the pool.
- """
-+ local_env = os.environ.copy()
-+ local_env["PATH"] = "../obj:%s" % local_env.get("PATH", "")
- sizes = set()
- out = ""
-- (rc, out) = bash("../obj/hugeadm --page-sizes")
-+ try:
-+ p = subprocess.Popen("hugeadm --page-sizes", shell=True, env=local_env, stdout=subprocess.PIPE)
-+ rc = p.wait()
-+ except KeyboardInterrupt:
-+ return sizes
-+ except OSError:
-+ return sizes
-+ out = p.stdout.read().strip()
-+
- if rc != 0 or out == "": return sizes
-
- for size in out.split("\n"): sizes.add(int(size))
---
-1.7.3.4
-
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/fix-lib64-can-not-be-shiped-in-64bit-target.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/fix-lib64-can-not-be-shiped-in-64bit-target.patch
deleted file mode 100644
index 676fa8a7..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/fix-lib64-can-not-be-shiped-in-64bit-target.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Upstream-Status: Inappropriate [oe-core specific]
-
-
-fix the below error:
- ERROR: QA Issue: libhugetlbfs: Files/directories were installed but not shipped
- /usr/lib64
- /usr/lib64/libhugetlbfs.so
- /usr/lib64/libhugetlbfs.a
- /usr/lib64/libhugetlbfs_privutils.so
- /usr/lib64/perl5
- /usr/lib64/perl5/TLBC
- /usr/lib64/perl5/TLBC/PerfCollect.pm
- /usr/lib64/perl5/TLBC/Report.pm
- /usr/lib64/perl5/TLBC/DataCollect.pm
- /usr/lib64/perl5/TLBC/OpCollect.pm
-$<50>ERROR: QA run found fatal errors. Please consider fixing them.
-
-
-Signed-off-by: Guo Chunrong <B40290@freescale.com>
-
---- a/Makefile 2013-09-23 02:28:57.340566998 -0500
-+++ b/Makefile 2013-09-23 02:31:05.344569896 -0500
-@@ -33,7 +33,6 @@
- CPPFLAGS += -D__LIBHUGETLBFS__ -DPPC_NO_SEGMENTS
-
- ARCH = $(shell uname -m | sed -e s/i.86/i386/)
--CC = gcc
-
- CUSTOM_LDSCRIPTS = yes
-
-@@ -59,9 +58,9 @@
- CUSTOM_LDSCRIPTS = no
- else
- ifeq ($(ARCH),aarch64)
--CC64 = gcc
-+CC64 = $(CC)
- ELF64 = aarch64elf
--TMPLIB64 = lib64
-+TMPLIB64 = lib
- CUSTOM_LDSCRIPTS = no
- else
- ifeq ($(ARCH),i386)
-@@ -72,7 +71,7 @@
- ifeq ($(ARCH),x86_64)
- CC64 = $(CC) -m64
- ELF64 = elf_x86_64
--TMPLIB64 = lib64
-+TMPLIB64 = lib
- TMPLIB32 = lib
- ifneq ($(BUILDTYPE),NATIVEONLY)
- CC32 = $(CC) -m32
-@@ -172,11 +171,23 @@
- BINDIR = $(PREFIX)/share/libhugetlbfs
- EXEDIR = $(PREFIX)/bin
- DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
-+
- ifdef CC32
- PMDIR = $(PREFIX)/lib/perl5/TLBC
-+endif
-+
-+ifdef CC64
-+ifeq ($(ARCH),x86_64)
-+PMDIR = $(PREFIX)/lib/perl5/TLBC
-+else
-+ifeq ($(ARCH),aarch64)
-+PMDIR = $(PREFIX)/lib/perl5/TLBC
- else
- PMDIR = $(PREFIX)/lib64/perl5/TLBC
- endif
-+endif
-+endif
-+
- MANDIR1 = $(PREFIX)/share/man/man1
- MANDIR3 = $(PREFIX)/share/man/man3
- MANDIR7 = $(PREFIX)/share/man/man7
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch
deleted file mode 100644
index b3fd8431..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/libhugetlbfs-avoid-search-host-library-path-for-cros.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-From 0a2877400a086e9d6ddd32a80462b7a931921dc2 Mon Sep 17 00:00:00 2001
-From: Chunrong Guo <B40290@freescale.com>
-Date: Sun, 8 Sep 2013 23:21:49 -0500
-Subject: [PATCH] libhugetlbfs: avoid search host library path for cross
- compilation
-
-Upstream-Status: Inappropriate [oe-core specific]
-
-Signed-off-by: Chunrong Guo <B40290@freescale.com>
----
- ldscripts/elf32ppclinux.xB | 2 +-
- ldscripts/elf32ppclinux.xBDT | 2 +-
- ldscripts/elf64ppc.xB | 2 +-
- ldscripts/elf64ppc.xBDT | 2 +-
- ldscripts/elf_x86_64.xB | 2 +-
- ldscripts/elf_x86_64.xBDT | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/ldscripts/elf32ppclinux.xB b/ldscripts/elf32ppclinux.xB
-index 28ad88d..33d482d 100644
---- a/ldscripts/elf32ppclinux.xB
-+++ b/ldscripts/elf32ppclinux.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf32-powerpc", "elf32-powerpc",
- "elf32-powerpc")
- OUTPUT_ARCH(powerpc:common)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf32ppclinux.xBDT b/ldscripts/elf32ppclinux.xBDT
-index 497882b..823475e 100644
---- a/ldscripts/elf32ppclinux.xBDT
-+++ b/ldscripts/elf32ppclinux.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf32-powerpc", "elf32-powerpc",
- "elf32-powerpc")
- OUTPUT_ARCH(powerpc:common)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf64ppc.xB b/ldscripts/elf64ppc.xB
-index 1a9c1ab..8cc557d 100644
---- a/ldscripts/elf64ppc.xB
-+++ b/ldscripts/elf64ppc.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-powerpc", "elf64-powerpc",
- "elf64-powerpc")
- OUTPUT_ARCH(powerpc:common64)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- PHDRS
- {
-diff --git a/ldscripts/elf64ppc.xBDT b/ldscripts/elf64ppc.xBDT
-index 5477294..53e0749 100644
---- a/ldscripts/elf64ppc.xBDT
-+++ b/ldscripts/elf64ppc.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-powerpc", "elf64-powerpc",
- "elf64-powerpc")
- OUTPUT_ARCH(powerpc:common64)
- ENTRY(_start)
--SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/powerpc64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/powerpc64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT( -lhugetlbfs );
- PHDRS
- {
-diff --git a/ldscripts/elf_x86_64.xB b/ldscripts/elf_x86_64.xB
-index ed21a2c..ba50e9f 100644
---- a/ldscripts/elf_x86_64.xB
-+++ b/ldscripts/elf_x86_64.xB
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-x86-64", "elf64-x86-64",
- "elf64-x86-64")
- OUTPUT_ARCH(i386:x86-64)
- ENTRY(_start)
--SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
-diff --git a/ldscripts/elf_x86_64.xBDT b/ldscripts/elf_x86_64.xBDT
-index 1855202..c62d245 100644
---- a/ldscripts/elf_x86_64.xBDT
-+++ b/ldscripts/elf_x86_64.xBDT
-@@ -3,7 +3,7 @@ OUTPUT_FORMAT("elf64-x86-64", "elf64-x86-64",
- "elf64-x86-64")
- OUTPUT_ARCH(i386:x86-64)
- ENTRY(_start)
--SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");
-+/*SEARCH_DIR("/usr/x86_64-linux-gnu/lib64"); SEARCH_DIR("/usr/local/lib64"); SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/x86_64-linux-gnu/lib"); SEARCH_DIR("/usr/local/lib"); SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib");*/
- INPUT(-lhugetlbfs);
- /* Do we need any of these for elf?
- __DYNAMIC = 0; */
---
-1.7.9.7
-
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch
deleted file mode 100644
index 07a99719..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 355c014573de7f95202cc7c819f81f0f230e4a1a Mon Sep 17 00:00:00 2001
-From: Ting Liu <b28495@freescale.com>
-Date: Mon, 18 Jun 2012 16:37:05 +0800
-Subject: [PATCH] skip checking LIB32 and LIB64 if they point to the same place
-
-Upstream-Status: Inappropriate [oe-core specific]
-Signed-off-by: Ting Liu <b28495@freescale.com>
----
-
-diff --git a/Makefile b/Makefile
-index 91502e1..bfb3414 100644
---- a/Makefile
-+++ b/Makefile
-@@ -167,7 +167,6 @@ REALLIB32 = $(realpath $(PREFIX)/$(LIB32))
- REALLIB64 = $(realpath $(PREFIX)/$(LIB64))
- ifneq ($(realpath $(PREFIX)),)
- ifeq ($(REALLIB32),$(REALLIB64))
--$(error LIB32 ($(PREFIX)/$(LIB32) to $(REALLIB32)) and LIB64 ($(PREFIX)/$(LIB64) to $(REALLIB64)) are resolving to the same place. Manually specify LIB32 and LIB64. e.g. make PREFIX=$(PREFIX) LIB32=lib32 LIB64=lib64)
- endif
- endif
-
---
-1.9.2
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch
deleted file mode 100644
index 249f6e1e..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/files/tests-Makefile-install-static-4G-edge-testcases.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream-Status: Submitted
-
-TESTS_64 is empty, install will fail due to missing file operand
-
-Signed-off-by: Ting Liu <b28495@freescale.com>
-
---- a/tests/Makefileold 2013-10-12 02:32:55.262391998 -0500
-+++ b/tests/Makefile 2013-10-12 02:33:45.929394722 -0500
-@@ -292,7 +292,7 @@
- $(INSTALL) -m 755 wrapper-utils.sh $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 $(HELPERS:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 $(HELPER_LIBS:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
-- $(INSTALL) -m 755 $(TESTS_64:%=obj64/%) $(DESTDIR)$(INST_TESTSDIR64)/obj64
-+ $(INSTALL) -m 755 $(TESTS_64_STATIC:%=obj64/%_static) $(DESTDIR)$(INST_TESTSDIR64)/obj64
- $(INSTALL) -m 755 run_tests.py $(DESTDIR)$(INST_TESTSDIR64)
-
- install: $(OBJDIRS:%=%/install)
diff --git a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/libhugetlbfs_git.bb b/meta-linaro-integration/recipes-overlayed/libhugetlbfs/libhugetlbfs_git.bb
deleted file mode 100644
index d3b64bfb..00000000
--- a/meta-linaro-integration/recipes-overlayed/libhugetlbfs/libhugetlbfs_git.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-SUMMARY = "A library which provides easy access to huge pages of memory"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
-
-DEPENDS = "sysfsutils perl"
-RDEPENDS_${PN} += "python python-io python-lang python-subprocess python-resource"
-
-PV = "2.18"
-PE = "1"
-
-SRCREV = "ea3f6b273f535aab38cefae30030774457bbbfe6"
-SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
- file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
- file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \
- file://tests-Makefile-install-static-4G-edge-testcases.patch \
- file://0001-run_test.py-not-use-hard-coded-path-.-obj-hugeadm.patch \
- file://0001-aarch64-fix-cross-compilation.patch \
- file://0001-aarch64-fix-page-size-not-properly-computed.patch \
- file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
-"
-
-S = "${WORKDIR}/git"
-
-COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*"
-
-LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
-EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"
-PARALLEL_MAKE_pn-${PN} = ""
-CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
-
-TARGET_CC_ARCH += "${LDFLAGS}"
-
-#The CUSTOM_LDSCRIPTS doesn't work with the gold linker
-do_configure() {
- if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
- fi
-
- # fixup perl module directory hardcoded to perl5
- sed -i 's/perl5/perl/g' Makefile
-}
-
-do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} \
- INST_TESTSDIR32=${libdir}/libhugetlbfs/tests \
- INST_TESTSDIR64=${libdir}/libhugetlbfs/tests \
- install-tests
-}
-
-
-PACKAGES =+ "${PN}-perl ${PN}-tests "
-FILES_${PN} += "${libdir}/*.so"
-FILES_${PN}-dev = "${includedir}"
-FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
-FILES_${PN}-perl = "${libdir}/perl"
-FILES_${PN}-tests += "${libdir}/libhugetlbfs/tests"
-
-INSANE_SKIP_${PN} = "dev-so"
-
-INHIBIT_PACKAGE_STRIP = "1"
-INHIBIT_PACKAGE_DEBUG_SPLIT = "1"